sdnoj1072(模拟)

1072.我们爱递归
Description

我们想明白递归函数到底是怎么运作的,所以想用递归来计算当给定一个正整数n(n < 16)时,求出n + (n-1)……+1的值,同时进行一些输出

要求写一个int plus1(int a)形式的函数,在进入递归函数时,输出相关信息。在调用结束返回值前,输出相关信息。最后输出n + (n-1)……+1的值

Input

3

Output

[plus1(3) output]Begin invoke plus1(3)

[plus1(3) output]I want to calculate plus1(3), require 3 and the value of plus1(2),so I need to invoke plus1(2)

[plus1(2) output]Begin invoke plus1(2)

[plus1(2) output]I want to calculate plus1(2), require 2 and the value of plus1(1),so I need to invoke plus1(1)

[plus1(1) output]Begin invoke plus1(1)

[plus1(1) output]return plus1(1) = 1

[plus1(2) output]I got the value of plus1(1), and plus it to 2then return3

[plus1(3) output]I got the value of plus1(2), and plus it to 3then return6

6

Sample Input

3

Sample Output

[plus1(3) output]Begin invoke plus1(3)
[plus1(3) output]I want to calculate plus1(3), require 3 and the value of plus1(2),so I need to invoke plus1(2)
[plus1(2) output]Begin invoke plus1(2)
[plus1(2) output]I want to calculate plus1(2), require 2 and the value of plus1(1),so I need to invoke plus1(1)
[plus1(1) output]Begin invoke plus1(1)
[plus1(1) output]return plus1(1) = 1
[plus1(2) output]I got the value of plus1(1), and plus it to 2then return3
[plus1(3) output]I got the value of plus1(2), and plus it to 3then return6
6

Hint

int plus1(int a)

{

// 从这里输出开始调用时的信息

if(a == 1)

{

// 从这里输出最后一次调用的返回信息

return ……;

}

else

{

// 从这里输出调用时的信息

// 开始进行递归调用下一步

……

int c = plus1(a - 1);

// 从这里输出返回值前的信息

……

return ……;

}

}

去年10月份做的这道题,错了很多遍,就放到了现在,刚刚又把这道题翻出来,在去年写的代码的输出上加了一个空格,竟然就ac了?????!!!!!
好搞笑啊哈哈哈
纯递归!开心!

#include<cstdio>
#include<iostream>
using namespace std;
int plus1(int a)
{
    printf("[plus1(%d) output]Begin invoke plus1(%d)\n",a,a);
    if(a==1)
    {
        printf("[plus1(1) output]return plus1(1) = 1\n");
        return 1;
    }
    else
    {
        printf("[plus1(%d) output]I want to calculate plus1(%d), require %d and the value of plus1(%d),so I need to invoke plus1(%d)\n",a,a,a,a-1,a-1);
        int c=plus1(a-1);
        printf("[plus1(%d) output]I got the value of plus1(%d), and plus it to %dthen return%d\n",a,a-1,a,a+c);
        return a+c;
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    printf("%d\n",plus1(n));
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值