Teacher Bo HDU - 5762(暴力+抽屉原理)

Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i-th point is at (Xi,Yi).He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,A≠CorB≠D) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print “YES”,else print “NO”.
Input
First line, an integer T. There are T test cases.(T≤50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates.(N,M≤105).

Next N lines, the i-th line shows the coordinate of the i-th point.(Xi,Yi)(0≤Xi,Yi≤M).
Output
T lines, each line is “YES” or “NO”.
Sample Input
2
3 10
1 1
2 2
3 3
4 10
8 8
2 3
3 3
4 4
Sample Output
YES
NO

题意

(cv一下别人的题意)这个题的意思是给你n和m,n代表n(x,y)个点,x和y的范围不会大于m,让你求这n个点之间的曼哈顿距离有没有重复的,有的话就输出“YES”,没有的话就输出“NO”。

思路:

完全可以暴力模拟,因为暴力最简单,但是n和m的范围是 1e5 ,想着会超时,但是又发现曼哈顿距离的范围是 2e5,最多跑 2e5 就会结束,而这个题刚好是要求是否有重复的,所以标记一下就好了,如果再次遇到这个距离,就输出“YES”,否则就输出“NO”。
然后利用抽屉原理,做多有2m个距离,如果代码中记录的曼哈顿距离个数超过了2m,那么一定有重复的曼哈顿距离,即可结束暴力模拟;总之不会超时;
用map标记如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <cmath>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
const int maxx=1e5+7;
int xx[maxx],yy[maxx];
map<int,int> mp;
int main()
{
    int t;
    cin >>t;
    while(t--)
    {
        mp.clear();
        int n,m;
        int ans=0;
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin >>xx[i]>>yy[i];
        }
        int dd;
        int flag=0;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                ans++;
                if(ans>2*m)
                {
                    flag=1;
                    break;
                }
                dd=abs(xx[i]-xx[j])+abs(yy[i]-yy[j]);
                if(mp[dd])
                {
                    flag=1;
                    break;
                }
                else mp[dd]=1;
            }
            if(flag)
                break;
        }
        if(!flag) cout <<"NO"<<endl;
        else cout <<"YES"<<endl;
    }
    return 0;
}

数组标记如下:

#include <iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>>
#include<cstring>

using namespace std;

const int maxn=1e5+7;
int b[2*maxn];
struct noad
{
    int x;
    int y;
}bb[maxn];//存点的坐标
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        memset(b,0,sizeof b);
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d %d",&bb[i].x,&bb[i].y);
        int cnt=0;
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                cnt++;
                if(cnt>2*m)
                {
                    flag=1;
                    break;
                }
                int sum=abs(bb[i].x-bb[j].x)+abs(bb[i].y-bb[j].y);
                if(b[sum]==0)
                {
                    b[sum]=1;
                }
                else
                {
                    flag=1;
                    break;
                }
            }
            if(flag) break;
        }
        if(flag) cout <<"YES"<<endl;
        else cout <<"NO"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值