Wave HDU - 6570

Avin is studying series. A series is called “wave” if the following conditions are satisfied:

  1. It contains at least two elements;
  2. All elements at odd positions are the same;
  3. All elements at even positions are the same;
  4. Elements at odd positions are NOT the same as the elements at even positions.
    You are given a series with length n. Avin asks you to find the longest “wave” subseries. A subseries is a subsequence of a series.
    Input
    The first line contains two numbers n, c (1 ≤ n ≤ 100, 000, 1 ≤ c ≤ 100). The second line contains n integers whose range is [1, c], which represents the series. It is guaranteed that there is always a “wave” subseries.
    Output
    Print the length of the longest “wave” subseries.
    Sample Input
    5 3
    1 2 1 3 2
    Sample Output
    4

题意:
从一个数字串中找到一个满足要求的字串,要求满足字串上奇数位置的数一样,偶数位置上的数相等,并且奇数位置和偶数位置上的数不一样,求这样的字串的长度的最大值;

思路;
如果一个字串满足要求,那么所包含的数一定是奇偶交叉排列的;
预处理把每个数出现的位置都保存下来;然后从1到c暴力枚举两个数,计算这两个数的所有存在位置中最大交叉长度为多少;不断更新这个最大交叉长度;

#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 1e5+7;

int main()
{
	int n,c,ans=0;
	cin>>n>>c;
	int t;
	vector<int> a[123];
	for(int i=1;i<=n;i++){
		scanf("%d",&t);
		a[t].push_back(i);//将每个数存在的位置存起来
	}
	for(int i=1;i<=c;i++)
	{
		for(int j=1;j<=c;j++)
		{	
			if(i==j) continue;
			int x = 0,y = 0,now=0;
			int len1 = a[i].size() ,len2 = a[j].size() ;
			int sum=0;
			
			while(1)
			{
				while(a[i][x] < now && x< len1) x++;//让两个数的位置交叉进行互换
				now = a[i][x];
				if(x==len1) break;//当其中一个数访问到头之后就结束比较
				sum++; 
				while(a[j][y] < now && y < len2) y++;
				now = a[j][y];
				if(y==len2) break;
				sum++;
			}
			ans = max(ans,sum);
		}
		
	} 
	cout<<ans<<endl;
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值