// DP Max Sum Plus Plus(最大M子段和问题)

22 篇文章 0 订阅

LINK :http://acm.hdu.edu.cn/showproblem.php?pid=1024

Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45134 Accepted Submission(s): 16369

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. _

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

dp[i][j]=max(dp[i][j-1]+a[j],dp[i-1][t]+a[j] (t<j))
dp[i][j]表示的是到a[j]为止 有i个子段的和的最大值

转移方程意思大概就是:

  • 前j-1个已经有i个子段了,把这个a[j]接在上个子段的后面~
  • 前面t (t<j&&t>=i) 已经有i-1个子段,再加上a[j]作为独立的子段
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1000010;
const ll inf=1e11;
ll s[N];
ll dp[N];
ll mm[N];
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        memset(dp,0,sizeof(dp)); 
        memset(mm,0,sizeof(mm));
    for(int i=1;i<=n;i++)
    {
        scanf("%lld",&s[i]);
    }ll maxx;
    for(int i=1;i<=m;i++)
    {
        maxx=-inf;
        for(int j=i;j<=n;j++)
        {
            //dp[i][j]=max(dp[i][j-1]+a[j],dp[i-1][t]+a[j](t<j)); 
            dp[j]=max(dp[j-1]+s[j],mm[j-1]+s[j]);
            mm[j-1]=maxx;
			//对于t<=j-1时候 也就是dp[i-1][t]的最大值 
			// 注意maxx  是针对于j-1
			// mm[j-1]的值必须在dp[j]进行之后再修改 如果在j-1时就改了 
			// mm[j-1] 代表的就是dp[i][t]了,gg了 
            maxx=max(maxx,dp[j]); 
        }
        
    }
    printf("%lld\n",maxx);        
    }

}

UP UP PANDA

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值