HDU1020——Encoding

Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.
    Input
    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.
    Output
    For each test case, output the encoded string in a line.
    Sample Input
    2
    ABC
    ABBCCC
    Sample Output
    ABC
    A2B3C

题解:

#include<stdio.h>
#include<string.h>
char a[10001],c[10001];    
int b[10001];
int main()
{
	int n,k;
	scanf("%d",&n);
	while(n--)
	{
		getchar();
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		scanf("%s",a);
		int l=0;
		for(int j=0;a[j] != '\0';j++)
		{
			if(a[j] == a[j+1])
				b[l]++;                //这个记录连续且相同的个数; 
			if(a[j] != a[j+1])
			{
				c[l]=a[j];             //这个记录连续的字符;
				l++; 
			}
		}
		for(int m=0; c[m] != '\0'; m++)
		{
			if(b[m]>0)
				printf("%d",b[m]+1);    //因为每个连续段的第一个字符都没算上,所以要在这里加上1;
			printf("%c",c[m]);
		}
		printf("\n");
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值