A1033 To Fill or Not to Fill (25分)(贪心算法的难题)

这道题是个人觉得贪心算法里面比较复杂的了。值得反复回看。
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​ , the unit gas price, and D​i(≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print “The maximum travel distance = X” where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17

Sample Input 2:
50 1300 12 2
7.10 0
7.00 600

Sample Output 2:
The maximum travel distance = 1200.00

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 510;
const int INF = 100000000;
struct station{
	double price, dis;
}st[maxn];

bool cmp (station a, station b){
	return a.dis < b.dis;
}

int main(){
	int n;
	double Cmax, D, Davg;
	cin >> Cmax >> D >> Davg >> n;
	for(int i = 0; i < n; i++){
		cin >> st[i].price >> st[i].dis;
	}
	st[n].price = 0;						//读入所有加油站数据之后添加终点加油站,油价为0,距离为最大距离D
	st[n].dis = D;
	sort(st, st + n, cmp);
	if(st[0].dis != 0){						//如果第一个加油站不在起点,那么无法前进,结束算法
		cout << "The maximum travel distance = 0.00\n";
	}else{
		int now = 0;						//now为当前所在加油站
		double ans = 0;						//ans为累计油费
		double nowTank = 0;					//nowTank为当前油量
		double MAX = Cmax * Davg;			//MAX为加满油箱能跑的最远距离
		while (now < n){					//每次循环找到下一个加油站
			//下面选出从当前加油站加满油能到达的范围内第一个油价比当前加油站低的加油站
			//如果没有比当前油价低的加油站,那么选择最低油价的加油站
			int k = -1;						//最低油价加油站的编号,若k = -1表示不能到达下一个加油站,结束算法
			double priceMin = INF;			//定义最低油价为无穷大
			for(int i = now + 1; i <= n && st[i].dis - st[now].dis <= MAX; i++){		//遍历能到达的所有站点
				if(st[i].price < priceMin){											//如果油价比当前最低油价低
					priceMin = st[i].price;											//更新最低油价 
					k = i;					//记录最低油价站点编号
					if(priceMin < st[now].price){								//如果这个油价比当前站点的油价低
						break;														//跳出循环
					}
				}
			}
			if(k == -1)	break;				//满油状态下无法到达任何加油站,结束算法
			//下面为能够到达下一站,计算转移花费钱数
			double need = (st[k].dis - st[now].dis) / Davg;	//need为从now到k所需要的油量
			if(priceMin < st[now].price){	//如果k站油价低于now站
				if(nowTank < need){			//如果现在的油量不足以到达k站
					ans += (need - nowTank) * st[now].price;	//只买能够到k的油
					nowTank = 0;		//到达k站,油量为0
				}else{		//如果现有油量足够到达k站
					nowTank -= need;	//直接到达k站
				}
			}else {			//如果k站油价now站
				ans += (Cmax - nowTank) * st[now].price;	//加满油
				nowTank = Cmax - need;		//到达k站
			}
			now = k;	//到达k站,进入下一层循环
		}
		if(now == n){	//如果能到达终点
			printf("%.2f\n", ans);		//输出油费
		}else{			//如果不能到达终点
			printf("The maximum travel distance = %.2f\n", st[now].dis + MAX);	//输出最大前进距离
		}
	}
	return 0;
}
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值