HDU-5879(打表 + 找规律)

题目描述:

题目链接

Given an integer n, we only want to know the sum of 1/(k * k) where k from 1 to n.

Input

There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
3
4
5
1
2
4
8
15

Sample Output

1
2
3
4
5
1.00000
1.25000
1.42361
1.52742
1.58044

题解:

需要注意的问题:

  1. 计算sum的时候不要1.0 / (i * i)这样计算, 要1.0 / i / i这样计算。
  2. 题目中没说n额具体范围, 只说了n >= 0 那就认为n无限大, 用字符串存储, 也同时意味着有规律可寻。

ac代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
//#include <bits/stdc++.h>
#include <iostream>
#include <stack>
#include "algorithm"
#include "cstdio"
#include "queue"
#include "set"
#include "cstring"
#include "string"
#include "map"
#include "vector"
#include "math.h"
#include "utility"   // pair头文件
#define esp 1e-6
using namespace std;
typedef long long ll;
typedef unsigned long long ull;

const int N = 1e6 + 5;
const int M = 1e9 + 5;

double a[N];
int main(){
    a[1] = 1;
    for (int i = 2; i < N; i++){
        a[i] = a[i - 1] + double(1.0 / i / i);
    }
    string n;
    while(cin >> n){
        if (n.size() >= 7)
            printf("%.5f\n",a[N - 1]);
        else{
            int m = atoi(n.c_str());// 将字符串转化为整型
            printf("%.5f\n",a[m]);
        }
    }
}
1
恰似你一低头的温柔,娇弱水莲花不胜寒风的娇羞, 我的心为你悸动不休。  --mingfuyan
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值