数据结构实验之链表五:单链表的拆分 SDUT

``## 数据结构实验之链表五:单链表的拆分 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6
1 3 15 999 9 1001

Hint

不得使用数组!
//

方法一(逆序建表):
#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
   struct node *head1,*head2,*p,*q;
   head1=(struct node*)malloc(sizeof(struct node));
   head1->next=NULL;
   head2=(struct node*)malloc(sizeof(struct node));
  head2->next=NULL;

   int n,a,b;
   a=b=0;
   scanf("%d",&n);
   while(n--)
   {
       p=(struct node*)malloc(sizeof(struct node));
       scanf("%d",&p->data);
       p->next=NULL;
       p->next=head1->next;
       head1->next=p;
   }
   q=head1->next;
   p=q->next;
   head1->next=NULL;
   while(q!=NULL)
   {
       if(q->data%2==0)
       {
           a++;
           q->next=head2->next;
           head2->next=q;

       }
       else
       {
           q->next=head1->next;
           head1->next=q;

           b++;

       }
       q=p;
       if(p!=NULL)
       {
           p=p->next;
       }

   }
   printf("%d %d\n",a,b);
   q=head1->next;
   p=head2->next;
   while(p!=NULL)
   {
       if(p->next==NULL)
        printf("%d\n",p->data);
       else printf("%d ",p->data);
       p=p->next;
   }
   while(q!=NULL)
   {
       if(q->next==NULL)
        printf("%d\n",q->data);
       else printf("%d ",q->data);
       q=q->next;
   }
   return 0;


}



/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 148KB
****************************************************/

方法二(顺序建表):
#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
   struct node *head1,*head2,*p,*q,*tail;
   head1=(struct node*)malloc(sizeof(struct node));
   head1->next=NULL;
   head2=(struct node*)malloc(sizeof(struct node));
   int n,a,b;
   a=b=0;
   scanf("%d",&n);
   tail=head1;
   while(n--)
   {
       p=(struct node*)malloc(sizeof(struct node));
       scanf("%d",&p->data);
       p->next=NULL;
       tail->next=p;
       tail=p;
   }
   q=head1->next;
   p=q->next;
   struct node*tail1,*tail2;
   tail2=head2;
   tail1=head1;
   head1->next=NULL;
   head2->next=NULL;
   while(q!=NULL)
   {
       if(q->data%2==0)
       {
           a++;
           q->next=NULL;
           tail2->next=q;
           tail2=q;
       }
       else
       {
           q->next=NULL;
           tail1->next=q;
           tail1=q;
           b++;

       }
       q=p;
       if(p!=NULL)
       {
           p=p->next;
       }
   }
   printf("%d %d\n",a,b);
   q=head1->next;
   p=head2->next;
   while(p!=NULL)
   {
       if(p->next==NULL)
        printf("%d\n",p->data);
       else printf("%d ",p->data);
       p=p->next;
   }
   while(q!=NULL)
   {
       if(q->next==NULL)
        printf("%d\n",q->data);
       else printf("%d ",q->data);
       q=q->next;
   }
   return 0;


}

方法三:
#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *next;
};

int main()
{
    int n;
    while(~scanf("%d",&n))
    {


        struct node*head1,*p1,*q1;
        struct node *head2;

        head1=(struct node*)malloc(sizeof(struct node));
        head1->next=NULL;
        q1=head1;
        int k=n;
        while(n--)
        {
            p1=(struct node*)malloc(sizeof(struct node));
            scanf("%d",&p1->data);
            p1->next=NULL;
            q1->next=p1;
            q1=p1;
        }
        struct node *p2,*r;
        int z=0;

        head2=(struct node*)malloc(sizeof(struct node));
        head2->next=NULL;
        p2=head2;
        r=head1;
        p1=r->next;


        while(p1!=NULL)
        {
            if(p1->data%2==0)
            {
                p2->next=p1;
                p2=p1;  //!!!
                r->next=p1->next;
                p2->next=NULL;  //  !!!!!!
                p1=r->next;
                z++;

            }
            else
            {
                r=r->next;
                p1=p1->next;
            }
        }
        printf("%d %d\n",z,k-z);
        p2=head2->next;
        while(p2!=NULL)
        {
            if(p2->next==NULL)  printf("%d\n",p2->data);
            else printf("%d ",p2->data);
            p2=p2->next;
        }
        p1=head1->next;
        while(p1!=NULL)
        {
            if(p1->next==NULL)  printf("%d\n",p1->data);
            else printf("%d ",p1->data);
            p1=p1->next;
        }

    }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值