HDU 1001 c++

HDU 1001

Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

#include <iostream>
using namespace std;
int main()
{
	int n;
	while (cin>>n)
	{
		int i=1,s=0;//连带着顺便给下一个循环初始化数值
		for(i=1;i<=n;i++)
		s=s+i;
		cout<<s<<endl<<endl;
//也可以在这一行初始化数值,i=1,s=0
	}
    return 0;	
}

s忘了初始化,卡了好久,问了老师才发现。
我应该是个智障。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值