HDU 1001
Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
#include <iostream>
using namespace std;
int main()
{
int n;
while (cin>>n)
{
int i=1,s=0;//连带着顺便给下一个循环初始化数值
for(i=1;i<=n;i++)
s=s+i;
cout<<s<<endl<<endl;
//也可以在这一行初始化数值,i=1,s=0
}
return 0;
}
s忘了初始化,卡了好久,问了老师才发现。
我应该是个智障。