Stones on the Table CodeForces - 266A

Stones on the Table CodeForces - 266A

Time limit:2000 ms Memory limit:262144 kB
Source:Codeforces Round #163 (Div. 2)
Tag:simplementation *800
Editorial:Announcement Tutoria

Problem Description:There are n stones on the table in a row, each of them can be red, green or blue. Count the minimum number of stones to take from the table so that any two neighboring stones had different colors. Stones in a row are considered neighboring if there are no other stones between them.

Input:The first line contains integer n (1 ≤ n ≤ 50) — the number of stones on the table.The next line contains string s, which represents the colors of the stones. We’ll consider the stones in the row numbered from 1 to n from left to right. Then the i-th character s equals “R”, if the i-th stone is red, “G”, if it’s green and “B”, if it’s blue.

Output:Print a single integer — the answer to the problem.

Sample Input:
3
RRG

Sample Output:1

Sample Input:

5
RRRRR

Sample Output:4

Sample Input:

4
BRBG

Sample Output:0

问题链接:Stones on the Table CodeForces - 266A
问题简述:有一排彩色的石头,问最少拿走几个时,每两个相邻的石头颜色不同。
问题分析:自己多写几个不同的序列,通过比较分析得出:当每两个相邻的颜色相同的石头拿掉其中一个时,拿的次数最少。
AC代码如下:

#include <iostream>
using namespace std;
int main()
{
	int n;
	char a[51];
	while (cin >> n)
	{
		int m, count = 0;
		cin >> a;
		for (m = 0; m < n; m++)
		{
			if (a[m] == a[m + 1])//当相邻两个石头颜色相同时,取出一个,次数加一
				count++;
		}
		cout << count << endl;
	}
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值