HDU-6629【2019 Multi-University Training Contest 5】【扩展kmp】

本文探讨了计算机科学中常见的字符串匹配问题,通过分析一个具体的字符串匹配案例,介绍了一种使用扩展KMP算法优化暴力匹配的方法,旨在减少比较操作次数,提高效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

string matching

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 835    Accepted Submission(s): 320

 

Problem Description

String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string s[0…len−1], please calculate the length of the longest common prefix of s[i…len−1] and s[0…len−1] for each i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:


We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.

Input

The first line contains an integer T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

* 1≤T≤30

* string length ≤106 for every string

Output

For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.

Sample Input

3 _Happy_New_Year_ ywwyww zjczzzjczjczzzjc

Sample Output

17 7 32

Source

2019 Multi-University Training Contest 5

题意

给一个字符串s,求每一个后缀和原串的最长公共前缀,给出暴力代码,问用暴力代码跑要比较几次

题解

签到题,套扩展kmp的next数组,把next全部加1,判断一下会不会超过len

代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 1000100
using namespace std;

char s[maxn];
int a[maxn];

void getNext(char x[], int m, int next[]){
    next[0] = m;
    int j = 0;
    while(j + 1 < m && x[j] == x[j + 1]) j++;
    next[1] = j;
    int k = 1;
    for(int i = 2; i < m; i++){
        int p = next[k] + k - 1;
        int L = next[i-k];
        if(i + L < p + 1) next[i] = L;
        else{
            j = max(0, p-i+1);
            while(i + j < m && x[i + j] == x[j]) j++;
            next[i] = j;
            k = i;
        }
    }
}

int main(){
    int t;
    cin >> t;
    while(t--){
        cin >> s;
        int len = strlen(s);
        getNext(s, len, a);
        long long sum = 0;
        for(int i = 1; i < len; i++){
            if(len - i < a[i] + 1) a[i] = len - i - 1;
            sum += a[i] + 1;
        }
        cout << sum << endl;
    }
}

 

内容概要:本文详细介绍了如何利用Simulink进行自动代码生成,在STM32平台上实现带57次谐波抑制功能的霍尔场定向控制(FOC)。首先,文章讲解了所需的软件环境准备,包括MATLAB/Simulink及其硬件支持包的安装。接着,阐述了构建永磁同步电机(PMSM)霍尔FOC控制模型的具体步骤,涵盖电机模型、坐标变换模块(如Clark和Park变换)、PI调节器、SVPWM模块以及用于抑制特定谐波的陷波器的设计。随后,描述了硬件目标配置、代码生成过程中的注意事项,以及生成后的C代码结构。此外,还讨论了霍尔传感器的位置估算、谐波补偿器的实现细节、ADC配置技巧、PWM死区时间和换相逻辑的优化。最后,分享了一些实用的工程集成经验,并推荐了几篇有助于深入了解相关技术和优化控制效果的研究论文。 适合人群:从事电机控制系统开发的技术人员,尤其是那些希望掌握基于Simulink的自动代码生成技术,以提高开发效率和控制精度的专业人士。 使用场景及目标:适用于需要精确控制永磁同步电机的应用场合,特别是在面对高次谐波干扰导致的电流波形失真问题时。通过采用文中提供的解决方案,可以显著改善系统的稳定性和性能,降低噪声水平,提升用户体验。 其他说明:文中不仅提供了详细的理论解释和技术指导,还包括了许多实践经验教训,如霍尔传感器处理、谐波抑制策略的选择、代码生成配置等方面的实际案例。这对于初学者来说是非常宝贵的参考资料。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值