HDU-6629【2019 Multi-University Training Contest 5】【扩展kmp】

本文探讨了计算机科学中常见的字符串匹配问题,通过分析一个具体的字符串匹配案例,介绍了一种使用扩展KMP算法优化暴力匹配的方法,旨在减少比较操作次数,提高效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

string matching

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 835    Accepted Submission(s): 320

 

Problem Description

String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string s[0…len−1], please calculate the length of the longest common prefix of s[i…len−1] and s[0…len−1] for each i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:


We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.

Input

The first line contains an integer T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

* 1≤T≤30

* string length ≤106 for every string

Output

For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.

Sample Input

3 _Happy_New_Year_ ywwyww zjczzzjczjczzzjc

Sample Output

17 7 32

Source

2019 Multi-University Training Contest 5

题意

给一个字符串s,求每一个后缀和原串的最长公共前缀,给出暴力代码,问用暴力代码跑要比较几次

题解

签到题,套扩展kmp的next数组,把next全部加1,判断一下会不会超过len

代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 1000100
using namespace std;

char s[maxn];
int a[maxn];

void getNext(char x[], int m, int next[]){
    next[0] = m;
    int j = 0;
    while(j + 1 < m && x[j] == x[j + 1]) j++;
    next[1] = j;
    int k = 1;
    for(int i = 2; i < m; i++){
        int p = next[k] + k - 1;
        int L = next[i-k];
        if(i + L < p + 1) next[i] = L;
        else{
            j = max(0, p-i+1);
            while(i + j < m && x[i + j] == x[j]) j++;
            next[i] = j;
            k = i;
        }
    }
}

int main(){
    int t;
    cin >> t;
    while(t--){
        cin >> s;
        int len = strlen(s);
        getNext(s, len, a);
        long long sum = 0;
        for(int i = 1; i < len; i++){
            if(len - i < a[i] + 1) a[i] = len - i - 1;
            sum += a[i] + 1;
        }
        cout << sum << endl;
    }
}

 

内容概要:本文详细介绍了QY20B型汽车起重机液压系统的设计过程,涵盖其背景、发展史、主要运动机构及其液压回路设计。文章首先概述了汽车起重机的分类和发展历程,强调了液压技术在现代起重机中的重要性。接着,文章深入分析了QY20B型汽车起重机的五大主要运动机构(支腿、回转、伸缩、变幅、起升)的工作原理及相应的液压回路设计。每个回路的设计均考虑了性能要求、功能实现及工作原理,确保系统稳定可靠。此外,文章还详细计算了支腿油缸的受力、液压元件的选择及液压系统的性能验算,确保设计的可行性和安全性。 适合人群:从事工程机械设计、液压系统设计及相关领域的工程师和技术人员,以及对起重机技术感兴趣的高等院校学生和研究人员。 使用场景及目标:①为从事汽车起重机液压系统设计的工程师提供详细的参考案例;②帮助技术人员理解和掌握液压系统设计的关键技术和计算方法;③为高等院校学生提供学习和研究起重机液压系统设计的实用资料。 其他说明:本文不仅提供了详细的液压系统设计过程,还结合了实际工程应用,确保设计的实用性和可靠性。文中引用了大量参考文献,确保设计依据的科学性和权威性。阅读本文有助于读者深入了解汽车起重机液压系统的设计原理和实现方法,为实际工程应用提供有力支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值