string matching
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 835 Accepted Submission(s): 320
Problem Description
String matching is a common type of problem in computer science. One string matching problem is as following:
Given a string s[0…len−1], please calculate the length of the longest common prefix of s[i…len−1] and s[0…len−1] for each i>0.
I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:
We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.
Input
The first line contains an integer T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.
* 1≤T≤30
* string length ≤106 for every string
Output
For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.
Sample Input
3 _Happy_New_Year_ ywwyww zjczzzjczjczzzjc
Sample Output
17 7 32
Source
2019 Multi-University Training Contest 5
题意
给一个字符串s,求每一个后缀和原串的最长公共前缀,给出暴力代码,问用暴力代码跑要比较几次
题解
签到题,套扩展kmp的next数组,把next全部加1,判断一下会不会超过len
代码
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 1000100
using namespace std;
char s[maxn];
int a[maxn];
void getNext(char x[], int m, int next[]){
next[0] = m;
int j = 0;
while(j + 1 < m && x[j] == x[j + 1]) j++;
next[1] = j;
int k = 1;
for(int i = 2; i < m; i++){
int p = next[k] + k - 1;
int L = next[i-k];
if(i + L < p + 1) next[i] = L;
else{
j = max(0, p-i+1);
while(i + j < m && x[i + j] == x[j]) j++;
next[i] = j;
k = i;
}
}
}
int main(){
int t;
cin >> t;
while(t--){
cin >> s;
int len = strlen(s);
getNext(s, len, a);
long long sum = 0;
for(int i = 1; i < len; i++){
if(len - i < a[i] + 1) a[i] = len - i - 1;
sum += a[i] + 1;
}
cout << sum << endl;
}
}