【题意+分析】1067 Sort with Swap(0, i) (25 分)_24行代码AC

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (≤10^​5) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1

Sample Output:
9


题意:每次只能以0所在的位置和某数交换,若想变为一个有序数列,问最小交换次数是多少。

算法逻辑:从贪心的角度看, 每次都将0所在位置和一个不在正确位置的数字交换显然为最优解。 那么,如果某次交换后,0回到了位置0上,就将其与随便一个不在正确位置上的数字交换即可。 其中贪心思想请读者仔细体会。


#include<bits/stdc++.h>
using namespace std;
int pos[100010];
int main() {
	int n; cin >> n;
	for(int i = 0; i < n; i++) {
		int x; cin >> x;
		pos[x] = i;
	}
	int cnt = 0; 
	for(int i = 0; i < n; i++) 
		if(pos[i] != i) {
			while(pos[0] != 0) {
				swap(pos[0], pos[pos[0]]); 
				cnt++;
			}
			if(pos[i] != i) {
				swap(pos[0], pos[i]);
				cnt++;
			}
		}
	cout << cnt; 
	return 0;
} 

耗时:

在这里插入图片描述


求赞哦~ (✪ω✪)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

来老铁干了这碗代码

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值