week15作业必做题(qh)

题意

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

输入格式:
首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
输出格式
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”
样例
Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output
light the wand
accio
what?
what?

思路

  • 此题利用的是哈希算法使得字符串和翻译对应起来,其中的难点是进行字符串的读取和存储,这里使用的是substr函数和find函数,将字典和翻译分别进行读取,然后计算各自的hash值,然后将其hash值及对应的索引值存入map中,这是读取和存储处理;
  • 接下来进行查询操作,首先判断是否存在,如果存在就判断查询的是单词还是翻译,如果是单词的话,翻译在map中的位置为单词+1;如果是翻译的话,对应的单词的位置为翻译的上一个;

总结

此题在输入的时候,是将【】算入单词的,因为在查询的时候同样输入的单词中有【】;

代码

#include<iostream>
#include<cstring>
#include<string>
#include<vector>
#include<cstdio>
#include<map>
using namespace std;
const int inf=1e9+7;
vector<string> a;
map<long long,int> ma;
long long has(string x)
{//计算hash值
	long long cn=0;
    for(int i=0;i<x.size();i++)
    {
    	cn=(cn+(long long )(x[i])*7)%inf;
    	cn=cn*7%inf;
    }
    return cn;
}
int main()
{

    string str;
	string str1,str2;
	int cnt=0;
	while(1)
	{
		getline(cin,str);
		if(str=="@END@")
			break;
		str1=str.substr(0,str.find("] ")+1);
		str2=str.substr(str.find("] ")+2,str.length()-str.find("] ")-1);
		a.push_back(str1);
		a.push_back(str2);
		long long temp1=has(str1);
		long long temp2=has(str2);

		ma.insert({temp1,cnt});//将单词的哈希值和index存入ma中
		cnt++;
		ma.insert({temp2,cnt});//将翻译的哈希值和数组的index存入ma中
		cnt++;
	}
	int n;
	cin>>n;
	getline(cin,str);
	for(int i=0;i<n;i++)
	{
		getline(cin,str);//输入查询的内容
		if(ma.find(has(str))!=ma.end())//需要查询的内容存在
		{
			if(str[0]=='[')//表明查询的为单词,要输出翻译
			{
				//根据存储的时候,单词对应的翻译在数组中位置位单词的下一个
				string ans_tranlate=a[ma[has(str)]+1];
				cout<<ans_tranlate<<endl;
			}
			else//表明输入的为翻译,要输出原单词
			{
				//根据存储的时候,翻译对应的单词在数组中的位置在翻译的上一个
				string ans_init=a[ma[has(str)]-1];
				ans_init=ans_init.substr(1,ans_init.size()-2);
				cout<<ans_init<<endl;
			}
		}
		else
			cout<<"what?"<<endl;
	}

	return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值