Expedition POJ - 2431 优先队列+贪心

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P
    Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
    Sample Input
    4
    4 4
    5 2
    11 5
    15 10
    25 10
    Sample Output
    2
    Hint
    INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题意:一辆车到目的地,需要经过很多加油站,每单位路程1的油费。每个加油站可以补充一些油。问最少经过多少加油站到达终点。没到达就输出-1

分析:我们可以这样思考,先让车开着,当没油的时候,我们看看前面是不是有加油站,如果有若干个加油站,那么我们就取最大的加油站。这里我们需要丢到一个优先队列里。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<functional>
#include<vector>
#define INF 0x3f3f3f3f
#define rep(i,x,y) for(int i=(x);i<=(y);i++)
#define down(i,x,y) for(int i=(x);i>=(y);i--)
#define il inline
#define db double
using namespace std;
int const N=10000+100;

int n;
int d,m;

struct node
{
	int dis;
	int oil;
}a[N];

bool cmp(node x,node y)
{
	return x.dis>y.dis;
}

priority_queue<int>pq;

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d%d",&a[i].dis,&a[i].oil);
	}
	sort(a,a+n,cmp);
	scanf("%d%d",&d,&m);
	int ans=0;//加油数
	int cnt=0;//下标
	pq.push(m);//当前油加入
	while(d>0&&!pq.empty())//当路程大于0并且队列不空
	{
		d-=pq.top();//每次减去对应的开的油
		ans++;
		pq.pop();
		while(d<=a[cnt].dis&&cnt<n)//将加油站在距离d里面的,都加入队列
		{
			pq.push(a[cnt++].oil); 
		}
	}
	if(d>0)printf("-1\n");//如果距离没有减到0或者负数,说明到不了
	else printf("%d\n",ans-1);//最后到达终点会多算一次,所以-1
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值