Expedition POJ - 2431 (贪心+优先队列)

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

解题思路:

我们创建一个优先队列,排序顺序是加油站的加油量的,每次汽车经过一个加油站,就把这个加油站放到优先队列里去,每当汽车的油量为0时,就把队列第一个加油站的油量加给汽车,以此类推直到汽车到达终点

如果汽车油量为0,此时队列为空且没有到达终点,那么就输出-1

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <stdio.h>
#include <string.h>
using namespace std;
int N,L,P;
int disFules[1000010];
int main() {
	while (~scanf("%d", &N)) {
		memset(disFules, -1, sizeof(disFules));
		priority_queue<int> fuelTanks;
		int dis, fuels;
		int ans = 0;
		for (int i = 0; i < N; ++i) {   //汽车经过时,读入数据
			scanf("%d %d", &dis, &fuels);
			disFules[dis] = fuels;  //燃料
		}
		scanf("%d %d", &L, &P); //读入L和P
		if (disFules[L] != -1) {
			fuelTanks.push(disFules[L]);
		}
		while (L) {
			L--,P--;
			if (disFules[L] != -1) {
				fuelTanks.push(disFules[L]);
			}
			if (P == 0) {
				if (L == 0) {
					break;
				}
				if (fuelTanks.empty()) {
					printf("-1\n");
					return 0;
				}
				P = fuelTanks.top();
				fuelTanks.pop();
				ans++;
				
			}
		}
		printf("%d\n", ans);
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值