Hdu 4006 The kth great number(vector和multiset)

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

题目原意是说输入I就代表要把I后面的数字加进去,输入Q就代表询问第K大的数字是多少。

思路分析

我开始的做法是每加入一个数就重新排序一遍,显然这样一定超时了。我想过不用重新排序只要插入数字就好,但奈何我的stl掌握的不牢固,所以没有想到,通过这道题也复习了vector和multiset的用法,multiset适用于重复数字,所以没有用set(set会把重复的数字删掉)。同时也借鉴了师哥的题解,师哥用的vector,后边只是添加数字,没有删除,这样已经很快了。我稍微改动了一下,把多余K个的数字都删掉了。vector的话需要自己排序,但是multiset是已经排序好的,所以我都试了一下,巩固学习。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
using namespace std;
int main()
{
    int n,k,A,i;
    char s;
    vector<int>V;
    while(cin>>n>>k)
    {
        V.clear();
    for(i=1;i<=n;i++)
    {
        cin>>s;
        if(s=='I')
        {
            cin>>A;
            int pos=lower_bound(V.begin(),V.end(),A)-V.begin();
            V.insert(V.begin()+pos,A);
            if(V.size()>k)
                V.erase(V.begin());
        }
        else
            cout<<V[0]<<endl;
    }
    }
}
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <set>
using namespace std;
int main()
{
    int i,k,A,n;
    char s;
   multiset<int>M;
   while(cin>>n>>k)
   {
       M.clear();
       for(i=1;i<=n;i++)
       {
           cin>>s;
           if(s=='I')
           {
               cin>>A;
               M.insert(A);
               if(M.size()>k)
                M.erase(M.begin());
           }
           else
            cout<<*M.begin()<<endl;
       }
   }
}

大家多多支持,大家一起进步吧!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值