This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
题意:输入两组数,每组中有M对数,分别为N,aN,输出总共有几对数,和这几对数之间的和。
思路:定义一个1010长度的数组a,每次碰到N相同的时候就a[i]+=num,输出的值按照N从大到小排序,所以只要从1010开始遍历到0只要这个索引下的数值不等于0就输出。
#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
using namespace std;
int main() {
int m,n;
double a[1010] = {0};
int b;
double num;
scanf("%d",&m);
for(int i = 0;i < m;i++) {
scanf("%d%lf",&b,&num);
a[b] += num;
}
scanf("%d",&n);
for(int i = 0;i < n;i++) {
scanf("%d%lf",&b,&num);
a[b] += num;
}
int cnt = 0;
for(int i = 1005;i >= 0;i--) {
if(a[i] != 0) {
cnt++;
}
}
printf("%d",cnt);
for(int i = 1005;i >= 0;i--) {
if(a[i] != 0) {
printf(" %d %.1lf",i,a[i]);
}
}
return 0;
}