PAT A1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​ −grade​M​​ . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

接下来是AC代码:

#include <iostream>
#include <cstdio> 
struct person{
	char id[15];  //id 
	char name[15]; //姓名 
	int score;  //分数 
}M,F,T;  //M为男生最低分的信息,F为女生最高分信息 
//初始化 
void init(){
	M.score=101;  //初始化男生的最低分数为较大值101 
	F.score=-1;   //初始化女生的最低分数为较小值-1 
}
int main(void) {
	int n;
	char sex;
	init();
	scanf("%d",&n);
	while(n--){
		scanf("%s %c %s %d",T.name,&sex,T.id,&T.score);
		if(sex=='M'&&T.score<M.score){
			M=T;   //更新M 
		}
		else if(sex=='F'&&T.score>F.score){
			F=T;   //更新F 
		}
	}
	//没有女生 
	if(F.score==-1){
		printf("Absent\n");
	}else{
		printf("%s %s\n",F.name,F.id);
	}
	//没有男生 
	if(M.score==101){
		printf("Absent\n");
	}else{
		printf("%s %s\n",M.name,M.id);
	}
	//没有女生或者男生 
	if(F.score==-1||M.score==101){
		printf("NA\n");
	}else{
		printf("%d\n",F.score-M.score);
	}
	return 0;
}

解题思路:
1.使用结构体存放姓名id分数
2.再读入信息的同时根据性别来进行分支判断如何操作
3.输出,判断结构体初始化的101和-1有没有被改变来进行选择输出
需要注意:
1.姓名和id都必须使用大小超过10的char数组来保存,如果只设置10,则会有数据丢失
2.输出时注意输出Absent和NA的情况

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

纳萨斯瓦德

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值