Frogger
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4
3
17 4
19 4
18 5
0
Sample Output
Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414
题目描述:
青蛙站在第一个石头上要跳往第二个石头,中间还有很多其他石头可以当作跳板,问它跳往第二个石头的路径中,最大要跳多少才能全部跳过,当然这个最大跳跃也是越小越好(题目有点绕,就是求所有路径中最大跳跃距离的最小值。)
解题思路:
Dijkstra算法的变形。因为终点是第二个,所以最后输出dis[2]即可。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define inf 99999999
using namespace std;
int main()
{
int n,g=0;
while(~scanf("%d",&n))
{
if(n==0)
break;
double x[210],y[210],dis[210],e[210][210];
int i,j,book[210],minx,u;
for(i=1;i<=n;i++)
scanf("%lf%lf",&x[i],&y[i]);
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(i==j)e[i][j]=0;
else
{
e[i][j]=e[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
}
}
memset(book,0,sizeof(book));
for(i=1;i<=n;i++)
dis[i]=e[1][i];
book[1]=1;
for(i=1;i<=n;i++)
{
minx=inf;
for(j=1;j<=n;j++)
{
if(!book[j]&&dis[j]<minx)
{
minx=dis[j];
u=j;
}
}
book[u]=1;
for(j=1;j<=n;j++)
{
dis[j]=min(dis[j],max(dis[u],e[u][j]));
}
} //注意题目格式,末尾两个换行。
printf("Scenario #%d\nFrog Distance = %.3f\n\n",++g,dis[2]); //终点是第二个石头,输出dis[2]
}
return 0;
}
错误分析:
这道题输出每组样例之间还要多输出一个空行。