POJ 3268 Silver Cow Party (Dijkstra最短路径)

Silver Cow Party

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题目描述:
给出点的个数,边的个数和聚会所在点,输出每一个点牛的来回距离和的最大值。注意是单向图。
解题思路:
属于最短路模板题,但是因为是单向图还要求往返距离,所以可以先求所有点到聚会点的距离存入dis1数组中,然后将边交换再求依此所有点到聚会点的距离存入dis2数组中,最后依次相加求最大值即可。
AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 99999999
int e[2010][2010],e1[2010][2010];
using namespace std;
int main()
{
    int n,m,x;
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {

        int i,j,k,minx,sum=0;
        int book[2010],dis1[2010],dis2[2010],dis[2010];
        memset(dis,0,sizeof(dis));
        memset(dis1,0,sizeof(dis1));
        memset(dis2,0,sizeof(dis2));
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
        {
            if(i==j)e[i][j]=e1[i][j]=0;
            else e[i][j]=e1[i][j]=inf;
        }
        for(i=1;i<=m;i++)
        {
            int t1,y,z;
            scanf("%d%d%d",&t1,&y,&z);
            e[t1][y]=z;
            e1[y][t1]=z;                //在这里交换边。
        }
        for(i=1;i<=n;i++)
            dis1[i]=e[x][i];
        memset(book,0,sizeof(book));
        book[x]=1;
        for(i=1;i<=n;i++)
        {
            minx=inf;
            int u;
            for(j=1;j<=n;j++)
            {
                if(book[j]==0&&dis1[j]<minx)
                {
                    minx=dis1[j];
                    u=j;
                }
            }
            book[u]=1;
            for(j=1;j<=n;j++)
                dis1[j]=min(dis1[j],dis1[u]+e[u][j]);
        }
        for(i=1;i<=n;i++)
            dis2[i]=e1[x][i];
        memset(book,0,sizeof(book));
        book[x]=1;
        for(i=1;i<=n;i++)
        {
            minx=inf;
            int u;
            for(j=1;j<=n;j++)
            {
                if(book[j]==0&&dis2[j]<minx)
                {
                    minx=dis2[j];
                    u=j;
                }
            }
            book[u]=1;
            for(j=1;j<=n;j++)
                dis2[j]=min(dis2[j],dis2[u]+e1[u][j]);
        }
        for(i=1;i<=n;i++)
            dis[i]=dis1[i]+dis2[i];
            int ans=0;
        for(i=1;i<=n;i++)
        {
            if(dis[i]>ans)
                ans=dis[i];
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值