HDU-1213 How Many Tables(并查集)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47751 Accepted Submission(s): 23796

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

Author
Ignatius.L

Source
杭电ACM省赛集训队选拔赛之热身赛

Recommend
Eddy

题目简述:

小明今天生日,摆酒请客。来了很多朋友,为了不让场面陷入尴尬,不能让不认识的朋友坐在一桌。(若A认识B,B认识C,则看作A,B,C三人互相认识)问要多少桌才坐得下。
第一行给出样例组数T(1<=T<=25)接下来给出T组输入。每组第一行给出朋友总数n,和m。m表示接下来m行,每行给出两个数字a,b,代表a和b相互认识。

题目分析:

很明显要用并查集。

代码实现:

#include<bits/stdc++.h>
using namespace std;

int p[1005];
int find(int a)
{
    int n=a,m=a,t;
    while(p[n]!=n)
    {
        n=p[n];
    }
    while(p[m]!=n)
    {
        t=p[m];
        p[m]=n;
        m=t;
    }
    return n;
}
void join(int a,int b)
{
    if(find(a)!=find(b)) p[p[a]]=find(b);
}

int main()
{
    int T,n,m,t1,t2,sum,i;
    scanf("%d",&T);
    while(T--)
    {
        sum=0;
        scanf("%d%d",&n,&m);
        for(i=0;i<=n;i++) p[i]=i;
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&t1,&t2);
            join(t1,t2);
        }
        for(i=1;i<=n;i++)
        {
            if(p[i]==i) sum++;
        }
        printf("%d\n",sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值