UVA - 1193 Radar Installation (贪心) (区间覆盖) (day_5_J)

Radar Installation

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each
small island is a point locating in the sea side. And any radar installation, locating on the coasting,
can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance
between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above
x-axis, and the land side below. Given the position of each island in the sea, and given the distance of
the coverage of the radar installation, your task is to write a program to find the minimal number of
radar installations to cover all the islands. Note that the position of an island is represented by its x-y
coordinates.
Figure 1: A Sample Input of Radar Installation
Input
The input consists of several test cases. The first line of each case contains two integers n (1 ≤ n ≤ 1000)
and d, where n is the number of islands in the sea and d is the distance of coverage of the radar
installation. This is followed by n lines each containing two integers representing the coordinate of the
position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros.
Output
For each test case output one line consisting of the test case number followed by the minimal number
of radar installations needed. ‘-1’ installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1

题目简述:

x轴以上为海,下为陆,海上有岛,在x轴建雷达,题目给出岛的坐标,问最少要几个雷达。

题目分析:

将区域覆盖转为区间覆盖,即雷达a(xa,0)能覆盖小岛b(xb,yb)的条件为,xb-sqrt(rr-yb)<xa<xb+sqrt(rr-yb)。

代码实现:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
//#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
#define pf          printf
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define ms(i,j) memset(i,j,sizeof(i))

int m;
double dd(double y)
{
    return(sqrt(m*m-y*y));
}
struct point
{
    int x,y;
    bool operator <(const point a) const
    {
        return x<a.x;
    }
};
point a[1005];
int main()
{
    int n,sum,j=1;
    double l,r,tl,tr;
    while(sff(n,m)&&n)
    {
        for(int i=0; i<n; i++)
            sff(a[i].x,a[i].y);
        sort(a,a+n);
        l=a[0].x-dd(a[0].y);
        r=a[0].x+dd(a[0].y);
        sum=1;
        if(a[0].y>m)
        {
            pf("Case %d: %d\n",j++,-1);
            continue;
        }
        for(int i=1; i<n; i++)
        {
            if(a[i].y>m)
            {
                sum=-1;
                break;
            }
            tl=a[i].x-dd(a[i].y);
            tr=a[i].x+dd(a[i].y);
            if(tl>r)
            {
                r=tr;
                sum++;
            }
            else if(tl<r&&tr<r)
                r=tr;
        }
        pf("Case %d: %d\n",j++,sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值