【35.53%】【POJ 2912】Rochambeau

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2837 Accepted: 1008
Description

N children are playing Rochambeau (scissors-rock-cloth) game with you. One of them is the judge. The rest children are divided into three groups (it is possible that some group is empty). You don’t know who is the judge, or how the children are grouped. Then the children start playing Rochambeau game for M rounds. Each round two children are arbitrarily selected to play Rochambeau for one once, and you will be told the outcome while not knowing which gesture the children presented. It is known that the children in the same group would present the same gesture (hence, two children in the same group always get draw when playing) and different groups for different gestures. The judge would present gesture randomly each time, hence no one knows what gesture the judge would present. Can you guess who is the judge after after the game ends? If you can, after how many rounds can you find out the judge at the earliest?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (1 ≤ N ≤ 500, 0 ≤ M ≤ 2,000) in one line, which are the number of children and the number of rounds. Following are M lines, each line contains two integers in [0, N) separated by one symbol. The two integers are the IDs of the two children selected to play Rochambeau for this round. The symbol may be “=”, “>” or “<”, referring to a draw, that first child wins and that second child wins respectively.

Output

There is only one line for each test case. If the judge can be found, print the ID of the judge, and the least number of rounds after which the judge can be uniquely determined. If the judge can not be found, or the outcomes of the M rounds of game are inconsistent, print the corresponding message.

Sample Input

3 3
0<1
1<2
2<0
3 5
0<1
0>1
1<2
1>2
0<2
4 4
0<1
0>1
2<3
2>3
1 0
Sample Output

Can not determine
Player 1 can be determined to be the judge after 4 lines
Impossible
Player 0 can be determined to be the judge after 0 lines
Source

Baidu Star 2006 Preliminary
Chen, Shixi (xreborner) living in http://fairyair.yeah.net/

【题解】

做法:
带权并查集
枚举某个人是裁判。如果它是裁判仍会发生冲突。那么就记录最先发生冲突的点在哪里;
(遇到和裁判有关的信息就直接跳过。因为裁判可以什么都出,所以它的信息没有意义。);
记录有多少个人满足:如果裁判是这个人整段信息不会发生冲突;
设为cnt;
如果cnt为0则说明不管谁是裁判都会发生冲突。则所给的信息是impossible的;
如果cnt为1则说明恰好有一个人满足裁判的要求。那么裁判就是他了。至于最早判断的地方就是其他n-1个不满足要求的裁判最早发生冲突的点的最大值。只有在那个信息结束后才能判断其他人不是裁判。
如果cnt大于1,则有多个人满足要求。那么就不能确定。
带权并查集的状态转移和食物链那题类似,我发下链接:
http://blog.csdn.net/harlow_cheng/article/details/52736452

#include <cstdio>
#include <algorithm>

const int MAXN = 600;
const int MAXM = 2999;

struct rec
{
    int x, y, z;
};

int n, m;
int f[MAXN], re[MAXN],fe[MAXN];
rec a[MAXM];
//0 same
//1 shu
//2 ying

int ff(int x)
{
    if (f[x] == x)
        return x;
    int olfa = f[x];
    f[x] = ff(f[x]);
    re[x] = (re[x] + re[olfa]) % 3;
    return f[x];
}

int main()
{
    //freopen("F:\\rush.txt", "r", stdin);
    while (~scanf("%d%d", &n, &m))
    {
        for (int i = 1; i <= m; i++)
        {
            char t;
            scanf("%d", &a[i].x);
            t = getchar();
            while (t == ' ')    t = getchar();
            scanf("%d", &a[i].y);
            if (t == '<')
                a[i].z = 1;
            else
                if (t == '>')
                    a[i].z = 2;
                else
                    a[i].z = 0;
        }
        for (int i = 0; i <= n - 1; i++)
            fe[i] = -1;
        for (int ju = 0; ju <= n - 1; ju++)
        {
            for (int i = 0; i <= n - 1; i++)
                f[i] = i, re[i] = 0;
            for (int i = 1; i <= m; i++)
            {
                if (a[i].x == ju || a[i].y == ju)
                    continue;
                int l = ff(a[i].x), r = ff(a[i].y);
                if (l == r)
                {
                    int temp = (re[a[i].x] - re[a[i].y] + 3) % 3;
                    if (temp != a[i].z)
                    {
                        fe[ju] = i;
                        break;
                    }
                }
                else
                {
                    f[l] = r;
                    re[l] = (a[i].z + re[a[i].y] - re[a[i].x] + 3) % 3;
                }
            }
        }
        int cnt = 0,judge,ma = 0;
        for (int i = 0; i <= n - 1; i++)
        {
            if (fe[i] == -1)
            {
                cnt++;
                judge = i;
            }
            ma = std::max(ma, fe[i]);
        }
        if (cnt == 0)
            puts("Impossible");
        else
            if (cnt == 1)
                printf("Player %d can be determined to be the judge after %d lines\n", judge, ma);
            else
                printf("Can not determine\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值