【43.49】【LA 3026】Period

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can bewritten as AK, that is A concatenated K times, for some string A. Of course, we also want to knowthe period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one containsN (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input fileends with a line, having the number zero on it.

Output

For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, foreach prefix with length i that has a period K > 1, output the prefix size i and the period K separatedby a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3


Test case #2

2 2

6 2

9 3

12 4

【题解】

就是用KMP算法去做吧。感觉不是很好的题。有点怪怪的。

记住这个结论就好i-f[i]是一个最长循环节的长度。

UPD1

找到了一个讲得比较好的博客:我是链接

【代码】

#include <cstdio>
#include <cstring>

const int MAX_SIZE = 1000100;

int lose[MAX_SIZE],n;
char s[MAX_SIZE];

void input_data()
{
	scanf("%s", s);
}

void get_ans()
{
	lose[0] = 0;
	lose[1] = 0;
	for (int i = 1; i <= n - 1; i++)
	{
		int j = lose[i];
		while (j && (s[i] != s[j])) j = lose[j];
		lose[i + 1] = (s[i] == s[j] ? j + 1 : 0);
	}
}

void output_ans()
{
	for (int i = 2; i <= n; i++)
		if (lose[i] > 0 && i % (i - lose[i]) == 0)
			printf("%d %d\n", i, i / (i - lose[i]));
	printf("\n");
}

int main()
{
	//freopen("F:\\rush.txt", "r", stdin);
	int t = 0;
	while (scanf("%d", &n) != EOF)
	{
		if (n == 0)
			break;
		t++;
		printf("Test case #%d\n",t);
		input_data();
		get_ans();
		output_ans();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值