1111 Online Map (30 分)

1111 Online Map (30 分)

Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:

V1 V2 one-way length time
where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.

Finally a pair of source and destination is given.

Output Specification:
For each case, first print the shortest path from the source to the destination with distance D in the format:

Distance = D: source -> v1 -> … -> destination
Then in the next line print the fastest path with total time T:

Time = T: source -> w1 -> … -> destination
In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.

In case the shortest and the fastest paths are identical, print them in one line in the format:

Distance = D; Time = T: source -> u1 -> … -> destination
Sample Input 1:
10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5
Sample Output 1:
Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5
Sample Input 2:
7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5
Sample Output 2:
Distance = 3; Time = 4: 3 -> 2 -> 5
题目大意:给定图中的点和边,每条边有边权距离和时间。然后分别求出距离最短的路径(若不唯一则取时间最短(保证唯一)),以及时间最短的路径(若不唯一则取路径中结点数最少的(保证唯一))。然后按要求输出
分析:使用两次Dijkstra算法分别求出距离最短和时间最短的路径,然后DFS取出符合要求的路径。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 510;
const int INF = (1 << 30) - 1;
struct node {
	int Dis, Tim;
	node() {
		Dis = INF;
		Tim = INF;
	}
};
int n, m, st, ed;
node G[maxn][maxn];
int d[maxn], t[maxn], num[maxn] = { 0 };
bool vis[maxn] = { false };
vector<int> dispre[maxn], timepre[maxn];
void Dijkstrad(int s) {
	fill(d, d + maxn, INF);
	memset(vis, false, sizeof(vis));
	d[s] = 0;
	num[s] = 1;
	for (int i = 0;i < n;++i) {
		int u = -1, MIN = INF;
		for (int j = 0;j < n;++j) {
			if (vis[j] == false && d[j] < MIN) {
				u = j;
				MIN = d[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;
		for (int v = 0;v < n;++v) {
			if (vis[v] == false && G[u][v].Dis != INF) {
				if (d[u] + G[u][v].Dis < d[v]) {
					d[v] = d[u] + G[u][v].Dis;
					num[v] = num[u];
					dispre[v].clear();
					dispre[v].push_back(u);
				}
				else if (d[u] + G[u][v].Dis == d[v]) {
					num[v] += num[u];
					dispre[v].push_back(u);
				}
			}
		}
	}
}
void Dijkstrat(int s) {
	fill(t, t + maxn, INF);
	memset(vis, false, sizeof(vis));
	t[s] = 0;
	for (int i = 0;i < n;++i) {
		int u = -1, MIN = INF;
		for (int j = 0;j < n;++j) {
			if (vis[j] == false && t[j] < MIN) {
				u = j;
				MIN = t[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;
		for (int v = 0;v < n;++v) {
			if (vis[v] == false && G[u][v].Tim != INF) {
				if (t[u] + G[u][v].Tim < t[v]) {
					t[v] = t[u] + G[u][v].Tim;
					num[v] = num[u];
					timepre[v].clear();
					timepre[v].push_back(u);
				}
				else if (t[u] + G[u][v].Tim == t[v]) {
					num[v] += num[u];
					timepre[v].push_back(u);
				}
			}
		}
	}
}
int minlenth = INF;
vector<int> timePath, ttempPath;
void tDFS(int v) {
	if (v == st) {
		ttempPath.push_back(v);
		int lenth = ttempPath.size();
		if (lenth < minlenth) {
			minlenth = lenth;
			timePath = ttempPath;
		}
		ttempPath.pop_back();
	}
	ttempPath.push_back(v);
	for (int i = 0;i < timepre[v].size();++i) {
		tDFS(timepre[v][i]);
	}
	ttempPath.pop_back();

}
int minTime = INF;
vector<int> disPath, tempPath;
void dDFS(int v) {
	if (v == st) {
		tempPath.push_back(v);
		int time = 0;
		for (int i = tempPath.size() - 1;i > 0;--i) {
			int u = tempPath[i], v = tempPath[i - 1];
			time += G[u][v].Tim;
		}
		if (time < minTime) {
			minTime = time;
			disPath = tempPath;
		}
		tempPath.pop_back();
	}
	tempPath.push_back(v);
	for (int i = 0;i < dispre[v].size();++i) {
		dDFS(dispre[v][i]);
	}
	tempPath.pop_back();

}
int main() {
	scanf("%d %d", &n, &m);
	for (int i = 0;i < m;++i) {
		int u, v, os, t, l;
		scanf("%d %d %d %d %d", &u, &v, &os, &l, &t);
		if (os) {
			G[u][v].Dis = l;
			G[u][v].Tim = t;
		}
		else {
			G[u][v].Dis = G[v][u].Dis = l;
			G[u][v].Tim = G[v][u].Tim = t;
		}
	}
	scanf("%d %d", &st, &ed);
	Dijkstrad(st);
	Dijkstrat(st);
	tDFS(ed);
	dDFS(ed);
	if (timePath == disPath) {
		printf("Distance = %d; Time = %d: ", d[ed], t[ed]);
		for (int i = disPath.size() - 1;i >= 0;--i) {
			if (i < disPath.size() - 1) printf(" -> ");
			printf("%d", disPath[i]);
		}
		printf("\n");
	}
	else {
		printf("Distance = %d: ", d[ed]);
		for (int i = disPath.size() - 1;i >= 0;--i) {
			if (i < disPath.size() - 1) printf(" -> ");
			printf("%d", disPath[i]);
		}
		printf("\nTime = %d: ", t[ed]);
		for (int i = timePath.size() - 1;i >= 0;--i) {
			if (i < timePath.size() - 1) printf(" -> ");
			printf("%d", timePath[i]);
		}
		printf("\n");
	}
	return 0;
}

写的有些冗长杂乱,没AC改的时候自己都头大

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值