1087 All Roads Lead to Rome (30 分)

该博客探讨了一种图论问题,即如何从起点城市找到通往罗马的最低成本路线,同时最大化途经城市的幸福感。通过Dijkstra算法寻找最短路径,并使用深度优先搜索在多条最低成本路径中选择幸福感最大或平均幸福感最大的路线。文章详细解释了算法实现过程,并提供了输入输出示例及代码解析。
摘要由CSDN通过智能技术生成

1087 All Roads Lead to Rome (30 分)

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2≤N≤200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N−1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:
For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness – it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->…->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

Sample Output:

3 3 195 97
HZH->PRS->ROM

题目大意:条条大路通罗马,给你图的信息,包括点权happiness和边权cost,找出cost最少的路径,如果有多条则找出happiness最大,还有多条则找出平均happiness最大,然后按要求输出;
分析:Dijkstra+DFS,用map分别存放string->int和int->string,average 是除去起点的average。

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
const int maxn = 210;
const int INF = (1 << 30) - 1;
int n, m, st, ed;
int weight[maxn] = { 0 }, G[maxn][maxn], d[maxn];
bool vis[maxn] = { false };
vector<int> pre[maxn];
vector<int> path, tempPath;
map<string, int> cityToIndex;
map<int, string> indexToCity;
void Dijkstra(int s) {
	fill(d, d + maxn, INF);
	d[s] = 0;
	for (int i = 0;i < n;++i) {
		int u = -1, MIN = INF;
		for (int j = 0;j < n;++j) {
			if (vis[j] == false && d[j] < MIN) {
				u = j;
				MIN = d[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;
		for (int v = 0;v < n;++v) {
			if (vis[v] == false && G[u][v] != INF) {
				if (d[u] + G[u][v] < d[v]) {
					d[v] = d[u] + G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if (d[u] + G[u][v] == d[v]) {
					pre[v].push_back(u);
				}
			}
		}
	}
}
int cnt = 0, maxHappi = -1, maxAveHappi = -1;
void DFS(int v) {
	if (v == st) {
		tempPath.push_back(v);
		++cnt;
		int happiness = 0, aveHappiness;
		for (int i = tempPath.size() - 1;i >= 0;--i) {
			int u = tempPath[i];
			happiness += weight[u];
		}
		aveHappiness = happiness / (tempPath.size() - 1);
		if (happiness > maxHappi) {
			maxHappi = happiness;
			maxAveHappi = aveHappiness;
			path = tempPath;
		}
		else if (happiness == maxHappi && aveHappiness > maxAveHappi) {
			maxAveHappi = aveHappiness;
			path = tempPath;
		}
		tempPath.pop_back();
		return;
	}
	tempPath.push_back(v);
	for (int i = 0;i < pre[v].size();++i) {
		DFS(pre[v][i]);
	}
	tempPath.pop_back();
}
int main() {
	string str1, str2;
	cin >> n >> m >> str1;
	cityToIndex[str1] = 0;
	indexToCity[0] = str1;
	fill(G[0], G[0] + maxn * maxn, INF);
	for (int i = 1;i < n;++i) {
		cin >> str1 >> weight[i];
		cityToIndex[str1] = i;
		indexToCity[i] = str1;
	}
	for (int i = 0;i < m;++i) {
		int l;
		cin >> str1 >> str2 >> l;
		int u = cityToIndex[str1], v = cityToIndex[str2];
		G[u][v] = G[v][u] = l;
	}
	st = 0, ed = cityToIndex["ROM"];
	Dijkstra(st);
	DFS(ed);
	cout << cnt << " " << d[ed] << " " << maxHappi << " " << maxAveHappi << endl;
	for (int i = path.size() - 1;i >= 0;--i) {
		if (i < path.size() - 1) cout << "->";
		cout << indexToCity[path[i]];
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值