hdu5137(最短路)

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things. 

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu. 

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.

Input

There are several test cases. 

For each test case: 

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000) 

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu. 

The input ends with N = 0 and M = 0. 

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.

Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

Sample Output

50
Inf

这道题调了很久很久才ac,变相的最短路,用另一个数组来存你劝说后的情况(即消除更这个人有关的关系),总共最多才30个人,怎么会超时呢,直接暴力枚举就好了,那你消除这个有关某个人的关系后,大老板肯定还是要找最便宜的啊,那你就把每种情况下的最便宜的钱中找一个最大的输出即可(把钱变成路程就变成了最短路了),就得到经过你的劝说后,大老板要花最多的钱,不过如果因为这个人被你劝说后(即消除了这个路),没办法到达校长那,那就输出Inf就好了

ac代码

​
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <cstdlib>
#include <queue>
#include<iomanip>
using namespace std;
const int inf = 0x7fffffff;
int p[35][35], q[35][35], s[35], g[35];
int n, m, ant, sum;
int disk()//这个就是Dijkstra算法
{
	int x;
	for (int i = 2; i <= n; i++)
	{
		if (q[1][i])s[i] = q[1][i];
		else s[i] = inf;

	}
	int kkk, l;
	for (int i = 1; i <= n; i++)
	{
		l = 0; kkk = inf;
		for (int j = 2; j <= n; j++)
		{
			if (kkk > s[j] && !g[j])
			{
				kkk = s[j];
				l = j;
			}
		}if (l == 0)break;
		g[l] = 1;
		for (int k = 2; k <= n; k++)
		{

			if (s[k] > s[l] + q[l][k] && q[l][k] && !g[k])//下次别用“l”这个字符了,居然被写成一,然后在那搞半天
				s[k] = s[l] + q[l][k];
		}



	}return s[n];
}
int main()
{
	int max = 0,kkk;
	while (cin >> n >> m)
	{
		if (n == 0 && m == 0)break;
		max = 0;
		memset(p, 0, sizeof(p));
		int a, b, c;
		for (int i = 0; i < m; i++)
		{
			cin >> a >> b >> c;
			p[a][b] = p[b][a] = c;
		}
		for (int i = 2; i < n; i++)
		{
			for (int k = 1; k <= n; k++)
			{
				for (int j = 1; j <= n; j++)
				{
					if (k != i && j != i)
						q[k][j] = p[k][j];
					else q[k][j] =0;//把有关这个人的关系全都消除,一开始把它设成Inf了,结果一直wa,搞不懂,都设为Inf了,那这条路肯定不会被考虑到啊;
				
				}

			}memset(g, 0, sizeof(g));
			kkk = disk(); //一开始用max = max > disk() ? max : disk(),真的是神经病了,这样每次不就调用了两次函数吗,肯定错的啊;

			max = max > kkk ? max : kkk;
		}if (max < inf)//没有办法到目的,即s[n]没有被更新到,看函数里对s【n】的赋值,则s【n】=inf。
			cout << max << endl;
		else cout << "Inf" << endl;
	}
}

​

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值