hdu-5137 “走关系” 最短路径

How Many Maos Does the Guanxi Worth
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 4084 Accepted Submission(s): 1576

Problem Description
“Guanxi” is a very important word in Chinese. It kind of means “relationship” or “contact”. Guanxi can be based on friendship, but also can be built on money. So Chinese often say “I don’t have one mao (0.1 RMB) guanxi with you.” or “The guanxi between them is naked money guanxi.” It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu’s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A “big money” means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net – it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help … If the request finally reaches the schoolmaster, Boss Liu’s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu’s plan. All you can do is to persuade ONE person in Boss Liu’s guanxi net to reject any request. This person can be any one, but can’t be Boss Liu or the schoolmaster. If you can’t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu’s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu’s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It’s guaranteed that Boss Liu’s request can reach the schoolmaster if you do not try to undermine his plan.

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print “Inf” instead.

Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

Sample Output
50
Inf
这道题一定要用scanf和printf!!!
f******************************kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk
2小时!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

#define _CRT_SECURE_NO_WARNINGS

#include<iostream>
#include<queue>
#include<stack>
#include <cstring>
using namespace std;
const int maxn = 50;
const int INF = 0x3f3f3f3f;
int map[maxn][maxn];  //邻接矩阵
bool vis[maxn];     //标记数组
int dis[maxn];         //源点到顶点i的最短距离
int path[maxn];         //记录最短路的路径
int enqueue_num[maxn];  //记录入队次数
int n;        //顶点数
int m;          //边数
int start=1;            //源点


bool SPFA()
{
	//memset(vis, 0, sizeof(vis));//这句是初始化
    memset(enqueue_num, 0, sizeof(enqueue_num));
    for (int i = 0; i < n; i++)
    {
        dis[i] = INF;
        path[i] = start;
    }

    queue<int> Q;
    dis[start] = 0;
    vis[start] = 1;
	Q.push(start);
    enqueue_num[start]++;
    while (!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vis[u] = 0;
        for (int v = 0; v < n; v++)
        {

			
 
                if (dis[u] + map[u][v] < dis[v])
                {
                    dis[v] = dis[u] + map[u][v];
                    path[v] = u;
                    if (!vis[v])
                    {
						vis[v] = 1;
                        Q.push(v);
                        enqueue_num[v]++;
                        if (enqueue_num[v] >= n)
                            return false;
                       
                    }
            }
        }
    }
    return true;
}

void Print()
{
    for (int i = 0; i < n; i++)
    {
        if (i != start)
        {
            int p = i;
            stack<int> s;
            cout << "顶点 " << start << " 到顶点 " << p << " 的最 路径是: ";

            while (start != p)  //路径顺序是逆向的,所以先保存到栈
            {
                s.push(p);
                p = path[p];
            }

            cout << start;
            while (!s.empty())  //依次从栈中取出的才是正序路径
            {
                cout << "--" << s.top();
                s.pop();
            }
            cout << "    最 路径长度是:" << dis[i] << endl;
        }
    }
}

void functest() {
	cout << "请输入图的顶点数,边数,源点:";
	cin >> n >> m >> start;

	for (int i = 0; i < n; i++)
		for (int j = 0; j < n; j++)
			map[i][j] = INF;  //初始化map数组

	cout << "请输入" << m << "条边的信息:\n";
	int u, v, w;
	for (int i = 0; i < m; i++)
	{
		cin >> u >> v >> w;
		map[u][v] = w;
	}

	if (SPFA())//
		Print();
	else
		cout << "Sorry,it have negative circle!\n";

	return ;
}

int main()
{
	while (scanf("%d %d",&n,&m)) {
		if (n == 0 && m == 0)break;
		n++;//n的数量要加一因为是0到n所以最后要输出n-1;
		start = 1;
		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++)
				map[i][j] = INF;

		while (m--) {
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			map[b][a]=map[a][b] = c;
		}


		int ans = -1;

		for (int i = 2; i < n - 1; i++) {
			memset(vis, 0, sizeof(vis));//这句是初始化
			vis[i] = 1;
			SPFA();
			if (dis[n - 1] > ans)ans = dis[n - 1];

		}
		if (ans >= INF)printf("Inf\n");
		else printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值