POJ3278(BFS)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

问题连接:http://poj.org/problem?id=3278

问题分析:利用BFS,一层一层搜索,知道找到牛的位置

AC代码:


#include<iostream>

#include<cstring>

#include<queue>

#define p 100010

using namespace std;

int visit[p];

int n,k;

struct Catch{

    int step;

    int x;

    Catch(int xx,int s):x(xx),step(s){}

};

queue<Catch> q;

int main(){

    scanf("%d %d",&n,&k);

    memset(visit,0,sizeof(visit));

    q.push(Catch(n,0));

    visit[n]=1;

    while(!q.empty()){

        Catch c=q.front();

        q.pop();

        if(c.x==k)

        {

            printf("%d\n",c.step);

            return 0;

        }

        else

        {

           if(c.x-1>=0&&!visit[c.x-1])

           {

               q.push(Catch(c.x-1,c.step+1));

               visit[c.x-1]=1;

               //printf("c1:%d\n",c.step+1);

           }

           if(c.x+1<p&&!visit[c.x+1])

           {

              q.push(Catch(c.x+1,c.step+1));

               visit[c.x+1]=1;

               //printf("c2:%d\n",c.step+1);

           }

           if(c.x*2<p&&!visit[c.x*2])

           {

              q.push(Catch(c.x*2,c.step+1));

               visit[c.x*2]=1;

               //printf("c3:%d\n",c.step+1);

           }

        }

 

    }

}

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值