Big Event in HDU
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53813 Accepted Submission(s): 18236
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
问题分析:
此问题包含多组数据,先将所有价值加起来,把总价值分成一半,因为题目要求左边输出的不能比右边小,但两者要尽可能相等,那么对sum/2做背包算法,使其价值最优为max,左边便输出sum-max。
贴代码
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int v[5005],dp[255555];
int main()
{
int n,i,j,l,a,b,sum;
while(cin>>n&&n>0)
{
memset(v,0,sizeof(v));
memset(dp,0,sizeof(dp));
l=0;sum=0;
for(i=0;i<n;i++)
{
cin>>a>>b;
while(b--)
{
v[l++]=a;
sum+=a;
}
}
for(i=0;i<l;i++)
{
for(j=sum/2;j>=v[i];j--)
{
dp[j]=max(dp[j],dp[j-v[i]]+v[i]);}
}
cout<<sum-dp[sum/2]<<" "<<dp[sum/2]<<endl;
}
}