寒假训练10-b

寒假训练10-b
(利用动态规划求最大子矩阵和)
问题:
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output
15

问题简述:先输入一个数字n代表n阶方阵,接着输入矩阵各元素,找出其中元素和最大的子矩阵,求出其和。
问题分析:求最大子矩阵,与求最大连续子序列的和相似,利用动态规划进行求解。

程序说明:先将矩阵中第(i,j)个元素变成该列前i个元素之和,以此类推,创建出一个新的矩阵,对此矩阵进行动态规划,利用循环对行与行用减法,列与列之间用加法,利用max变量将最大值打印出。
代码如下:

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
     int dp[200][200],a[200][200], n;
     while (scanf_s("%d", &n) != EOF)
 {
     memset(dp, 0, sizeof(dp));
     int sum, max =0;
  for (int i = 1; i <= n; i++)
  {
      for (int j = 1; j <= n; j++)
   {
      cin >> a[i][j];
       dp[i][j] =a[i][j] + dp[i - 1][j];//**创建新的矩阵**
   }
  }
  for (int i = 1; i <= n; i++)
  {
   for (int j = i; j <= n; j++)
   {
      int sum1 = 0;
      for (int k = 1; k <= n; k++)
    {
       sum = dp[j][k] - dp[i - 1][k];//**进行动态规划**
       sum1 += sum;
       if (sum1 < 0)sum1 = 0;
       if (sum1 > max)max = sum1;
    }
   }
  }
    cout << max << endl;
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值