SDU程序设计思维与实践Week12 【POJ2955】Brackets 【区间DP】

Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

思路分析

  • d p [ i ] [ j ] dp[i][j] dp[i][j]表示区间 [ i , j ] [i,j] [i,j]内最大的匹配数。
  • 判断第 i i i个数和第 j j j个数是不是匹配括号,如果是,那么 d p [ i ] [ j ] = d p [ i + 1 ] [ j − 1 ] + 2 dp[i][j]=dp[i+1][j-1]+2 dp[i][j]=dp[i+1][j1]+2
  • 先枚举区间长度len,再枚举左端点i,这样右端点即为 i + l e n − 1 i+len-1 i+len1,利用子问题的解来更新答案 d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k ] [ j ] ) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j])

代码

#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
string s;
int dp[105][105],n;
int main(){
	while(true){
		cin>>s;
		if(s=="end") break;
		n=s.length();
		memset(dp,0,sizeof dp);
		for(int len=2;len<=n;len++){
			for(int i=0;i<n-len+1;i++){
				int j=i+len-1;
				if(s[i]=='('&&s[j]==')'||s[i]=='['&&s[j]==']'){
					dp[i][j]=dp[i+1][j-1]+2;
				}				
				for(int k=i;k<j;k++){
					dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
				}
			}
		}
		cout<<dp[0][n-1]<<endl;
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值