SDU 程序设计思维与实践 Week 15 ZJM 与霍格沃兹【字符串Hash】

ZJM 与霍格沃兹

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

输入

首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:
[魔咒] 对应功能。
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

输入样例

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

输出样例

light the wand
accio
what?
what?

思路分析

如果建立map<stirng,string>会MLE
将字符串Hash后变为一个int建立map<int,string>映射。
利用ASCII码进行Hash

代码

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
using namespace std;
int N;
map<unsigned long long,string> mp;
string temp;
unsigned long long Hash(string s){
	unsigned long long ret=0;
	int seed=7,mod=1e9+7; 
	for(int i=0;i<s.size();i++){
		ret=ret*seed+s[i];
	}
	return ret;
}
int main(){
	while(getline(cin,temp)&&temp!="@END@"){
		int l=temp.find("[");
		int r=temp.find("]");
		string magic=temp.substr(l+1,r-l-1);
		string func=temp.substr(r+2);
		mp[Hash(func)]=magic;
		mp[Hash(magic)]=func; 
	}
	cin>>N;cin.get();
	for(int i=0;i<N;i++){
		getline(cin,temp);
		if(temp[0]=='['){
			temp=temp.substr(1,temp.size()-2);			
		}
		if(mp.find(Hash(temp))!=mp.end()){
			cout<<mp[Hash(temp)]<<endl;
			continue;
		}
		cout<<"what?"<<endl;
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值