6 I

UVA 10020

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].
Input
The first line is the number of test cases, followed by a blank line. Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”( |Li|,|Ri|≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair‘ 0 0’. Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be printed. If [0,M] can not be covered by given line segments, your programm should print ‘0’ (without quotes). Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1 -1 0 -5 -3 2 5 0 0
1 -1 0 0 1 0 0
Sample Output
0
1 0 1

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100000+100;
struct node
{
    int l;
    int r;
}line[maxn];
bool cmp(node a,node b)
{
    return a.r>b.r;
}
int m;
bool vis[maxn];
int ans[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&m);
        int x,y;
        int tot=0;
        while(scanf("%d%d",&x,&y)&&(x||y))
        {
             if(y<=0||x>=m) continue;
             line[tot].l=x;
             line[tot++].r=y;
        }
        sort(line,line+tot,cmp);
        //cout<<tot<<endl;
        int sr=0;
        memset(vis,false,sizeof(vis));//用来标记该线段有没有被使用
        memset(ans,0,sizeof(ans));
        int ant=0;
        while(sr<m)
        {
            bool flag=false;//判断是否找到
            for(int i=0;i<tot;i++)
            {
                if(!vis[i]&&line[i].l<=sr&&line[i].r>sr)
                {
                    vis[i]=true;
                    ans[ant++]=i;
                    sr=line[i].r;//更新右端点
                    flag=true;
                }
            }
           //cout<<sr<<endl;
            if(!flag) break;//未找到符合条件的线段
        }
        if(sr>=m)
        {
            printf("%d\n",ant);
            for(int i=0;i<ant;i++)
            {
                printf("%d %d\n",line[ans[i]].l,line[ans[i]].r);
            }
        }
        else  printf("0\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值