UVA 11264
Our dear Sultan is visiting a country where there are n different types of coin. He wants to collect as many different types of coin as you can. Now if he wants to withdraw X amount of money from a Bank, the Bank will give him this money using following algorithm.
withdraw(X){ if( X == 0) return; Let Y be the highest valued coin that does not exceed X. Give the customer Y valued coin. withdraw(X-Y); }
Now Sultan can withdraw any amount of money from the Bank. He should maximize the number of different coins that he can collect in a single withdrawal.
Input
First line of the input contains T the number of test cases. Each of the test cases starts with n (1 ≤ n ≤ 1000), the number of different types of coin. Next line contains n integers C1, C2, …, Cn the value of each coin type. C1 < C2 < C3 < … < Cn < 1000000000. C1 equals to 1.
Output
For each test case output one line denoting the maximum number of coins that Sultan can collect in a single withdrawal. He can withdraw infinite amount of money from the Bank.
Sample Input
2 6 1 2 4 8 16 32 6 1 3 6 8 15 20
Sample Output
6 4
这道题是找最多能换多少种硬币。
由于要最多,钱又能无限多,所以必定能拿到最大面与最小面额的硬币,
从最小面额的硬币开始,只要前面所选硬币总值小于下一枚硬币,那么下一枚硬币就可选。
#include <iostream>
using namespace std;
int main()
{
int n, m, a[1000], b, c, s;
cin >> n;
while (n--)
{
cin >> m; b = 0;
for (int i = 1; i <= m; i++)
cin >> a[i];
if (m <= 2)cout << m << endl;
else
{
c = a[1], s = 2;
for (int i = 2; i < m ; i++)
{
if (c < a[i]&&c+a[i]<a[i+1])
c = c + a[i],s++;
}
}
cout << s << endl;
}
}