4 I 高精度算法

UVA 424

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. “Thissupercomputerisgreat,”remarkedChip. “IonlywishTimothywereheretoseetheseresults.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). The final input line will contain a single zero on a line by itself.

Output Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

高精度算法
用一个数组保存结果
每一次输入都用一个字符串来接收,然后再逆序相加,逐位相加。
最后再输出。

#include<cstring>
#include<algorithm>
#include <iostream>
using namespace std;

int sum[111] = { 0 };
int main()
{
	int a[100] = { 0 }, b;
	string str;
	while (1)
	{
		cin >> str;
		if (str[0] == '0')
			break;
		b = (int)str.size();
		for (int i = 0; i < b; i++)
			a[i] = str[b - i - 1] - '0';
		for (int i = 0; i < b; i++)
		{
			int temp = a[i] + sum[i];
			sum[i] = temp % 10;
			sum[i + 1] += temp / 10;
		}
	}
	int i;
	for (i = 100; i >= 0; i--)
		if (sum[i])
			break;
	for (; i >= 0; i--)
		cout << sum[i];
	cout << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值