Stones on the Table解决方法

Problem Description
There are n stones on the table in a row, each of them can be red, green or blue. Count the minimum number of stones to take from the table so that any two neighboring stones had different colors. Stones in a row are considered neighboring if there are no other stones between them.
Input
The first line contains integer n (1 ≤ n ≤ 50) — the number of stones on the table.
The next line contains string s, which represents the colors of the stones. We’ll consider the stones in the row numbered from 1 to n from left to right. Then the i-th character s equals “R”, if the i-th stone is red, “G”, if it’s green and “B”, if it’s blue.
Output
Print a single integer — the answer to the problem.
Sample Input

3
RRG

Sample Output

1
问题简述:
输入石头数,然后输入石头各颜色,从其中取出石头,使相邻石头不同颜色。输出取的最少次数。
问题分析:
另外设置一个整形变量,作为输出的“次数”,每发现相邻相同颜色,则增加一次。
c++语言程序如下:

#include <iostream>
using namespace std;
int main()
{
 char*a; 
 int n;
 cin >> n;
 a = new char[n];
 cin >> a;
 int t = 0;
 for (int i = 0; i < n - 1; i++)
  if (a[i] == a[i + 1]) t++;
 cout << t;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值