HDU - 1213 How Many Tables

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213
问题解析:运用并查集。(一个易错点是要在while里面把k赋值为0。)

AC的代码如下:

#include<iostream>
using namespace std;
int arr[10000];
int find(int i)
{
	if (arr[i] == i)
		return arr[i];
return find(arr[i]);
}
void bcj(int x, int y)
{
	int a, b;
	a = find(x);
	b = find(y);
	if (a == b)
		return;
	else
		arr[b] = a;
}
int main()
{
	int n,x,y,k=0;
	cin >> n;
	while (n--)
	{
		k = 0;
		int a, b;
		cin >> a >> b;
		for (int i = 0; i <= a; i++)
			arr[i] = i;
		for (int i = 0; i < b; i++)
		{
			cin >> x >> y;
			bcj(x, y);
		}
		for (int i = 1; i <= a; i++)
			if (arr[i] != i)
				k++;
		printf("%d\n",a-k);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值