并查集-杭电1213-How Many Tables-难度1

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4

题目要求:求连通分量数,就是求tree[x] == -1 的节点个数

#include <iostream>
using namespace std;

const int MAX = 1001;
int friends[MAX];

int findRoot(int x)
{
	if(friends[x] == -1)
		return x;//如果x是根节点,则返回x
	else
	{
		friends[x] = findRoot(friends[x]);//如果x不是根节点,则查找x上一个节点的根节点
		//并且把x的上一节点赋值为根节点
		return friends[x];// 一定要返回根节点
	}
}
int main()
{
	//freopen("F:\\input.txt", "r", stdin);
	//freopen("F:\\output.txt", "w", stdout);
	int T, N, M;//T 测试组数, N表示朋友总数, M表示朋友对数
	cin >> T;
	while(T--)
	{
		cin >> N >> M;
		for(int i = 1; i < MAX; i++)
		{
			friends[i] = -1;
		}
		for(int i = 0; i != M; ++i )
		{
			int a, b;// a,b 表示输入的两个节点
			cin >> a >> b;
			int x, y;
			x = findRoot(a);
			y = findRoot(b);// x, y分别表示a,b的根节点
			if(x != y)
			{
				friends[x] = y;
			}
		}
		int tableNum = 0;
		for(int i = 1; i <= N; i++)
		{
			if(friends[i] == -1)//判断是不是根节点
				tableNum++;//tableNum 表示需要的桌子
		}
		cout << tableNum << endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值