The Suspects

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 52909 Accepted: 25191
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

问题链接:The Suspects.

问题简述:

有n个学生,m个社团。(0<n<=3000)(0<=m<=500)
学生学号从0到n-1。
已知0号学生已感染病毒。每个学生可能参加多个社团。
输入:
第一行,两个整数n,m;(当n=m=0时,结束)
接下来的m行输入一个数k(这个社团的人数),后跟学生的编号。
输出:
对于每一个例子,输出一个数代表可能感染的总人数,占一行。

问题分析:

明显是有和零号有接触的人都有事,只要将有联系的人分入同一组即可。(用并查集)

程序说明:

AC通过的C语言程序如下:

/*并查集
将n个物品归于不同集合中,不同集合中的物品绝对没有关系。
应用:
1.关系网,道路是否连通
2.是否感染
3.是否是同一个老大的组织
*/

#include<stdio.h>
#include<iostream>
using namespace std;

//stu[max]保存每个人的boss编号,num[max]是本题特有的保存BOSS的小弟数
int stu[30000],num[30000],n,m;

//a[max]是本题特有的输入过程中的数。
int a[30000];

//用于恢复初始值
void init()
{
	for(int i = 0;i<n;i++)
	{
		stu[i] = i;
		num[i] = 1;
	}
	return;
}

//用于查找a的boss
int boss(int a)
{
	if(stu[a]==a)
	{
		return a;
	}
	else
	{
		stu[a] = boss(stu[a]);//使找到的人都归入同一个boss旗下,避免过多的层级关系。
		return stu[a];
	}
}

//用于将a,b两人归入同一伙人
void find(int a,int b)
{
	int ia = boss(a),ib = boss(b);
	if(ia==ib)
	{
		return;
	}
	else
	{
		stu[ia] = ib;
		num[ib] = num[ia] + num[ib];
		return;
	}
}

int main()
{
	scanf("%d%d",&n,&m);
	while(n||m)
	{
		init();
		while(m--)
		{
			int k;
			scanf("%d",&k);
			for(int i = 0;i<k;i++)
			{
				scanf("%d",&a[i]);
			}
			for(int i = 0;i<k-1;i++)
			{
				find(a[i],a[i+1]);
			}
		}
		int ans = num[boss(0)];
		printf("%d\n",ans);
		scanf("%d%d",&n,&m);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值