Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.
Input
The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:
x1 x2 c
x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.
All the numbers are in the range [0, 8000], and they are all integers.
Input may contain several data set, process to the end of file.
Output
Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can't be seen, you shouldn't print it.
Print a blank line after every dataset.
Sample Input
5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
Sample Output
1 1
2 1
3 1
1 1
0 2
1 1
大意:
对每个给定的区间进行染色,最后统计每种颜色的线段条数。
分析:
基础的线段树操作,只不过为了好查询,最后query函数需要把颜色全部push到叶节点上并存入数组,以便统计。
代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 8010;
struct node
{
int l, r;
int col;
}t[maxn << 2];
vector<int> res;
int ans[maxn];
void pushdown(int tar)
{
if (t[tar].col != -1)
{
t[tar << 1].col = t[tar << 1 | 1].col = t[tar].col;
t[tar].col = -1;
}
}
void build(int l, int r, int tar)
{
t[tar].l = l, t[tar].r = r, t[tar].col = -1;
if (l == r) return;
int mid = (l + r) >> 1;
build(l, mid, tar << 1);
build(mid + 1, r, tar << 1 | 1);
}
void update(int l, int r, int col, int tar)
{
if (t[tar].l == l && t[tar].r == r)
{
t[tar].col = col;
return;
}
pushdown(tar);
int mid = (t[tar].l + t[tar].r) >> 1;
if (r <= mid) update(l, r, col, tar << 1);
else if (l > mid) update(l, r, col, tar << 1 | 1);
else update(l, mid, col, tar << 1), update(mid + 1, r, col, tar << 1 | 1);
}
void query(int tar)
{
if (t[tar].l == t[tar].r)
{
res.push_back(t[tar].col);
return;
}
pushdown(tar);
query(tar << 1);
query(tar << 1 | 1);
}
int main()
{
int n;
while (cin >> n)
{
int l, r, c;
build(1, 8000, 1);
memset(ans, 0, sizeof(ans));
res.clear();
while (n--)
{
scanf("%d%d%d", &l, &r, &c);
update(l + 1, r, c, 1);
}
query(1);
int last = -1;
for (int i = 0; i < res.size(); i++)
if (res[i] != last)
{
last = res[i];
if(res[i] != -1)
ans[res[i]]++;
}
for (int i = 0; i <= 8000; i++)
if (ans[i])
cout << i << " " << ans[i] << endl;
cout << endl;
}
}