Prim算法---最小生成树

图片来源:https://blog.csdn.net/qq_34793133/article/details/80633494
prim算法思路:
每次从未标记的结点中选择一个权值最小的进行标记,将此结点进行标记,直到所有结点均被标记,所得到的即为最小生成树。
具体过程如下:
(1)dis[]为当前结点所连的最小权值的边的值,vis[]表示此节点是否被标记
首先dis[]数组赋初值,均为结点v1到其结点的距离,如果无法到达即为inf。
将v1标记,vis[1]=1。
在这里插入图片描述
(2)从1结点寻找权值最小的边,为v3,距离为1,将ans+=1,标记v3结点。重新更新dis[]数组,原先dis[2]的值为v1-v2=6,加入v3结点后,v2-v3=5,数值更小,更新数组,以此类推。
在这里插入图片描述
(3)遍历dis数组,v3-v6为4,在所有数中最小,将v6结点加标记。在这里插入图片描述
(4)
在这里插入图片描述
(5)
在这里插入图片描述
(6)在这里插入图片描述

E - Agri-Net
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28
题意:
给你n个农场,然后给你农场之间要连通网络所需要的距离数,然后让你求出要想使所有农场都连通,最少需要多少距离。

#include <cstring>
#include <iostream>
#include <cstdio>
using namespace std;
#define Inf 0x3f3f3f3f
int m;
int ma[101][101];
int vis[101];
int dis[101];
int point[101];
int sum=0;

int Prim(int u)
{
    int tp=ma[u][1];
    for(int i=1; i<=m; i++)
        dis[i]=ma[u][i];
    vis[u]=1;//
    for(int i=2; i<=m; i++)
    {
        int temp, minn=Inf;
        for(int j=1; j<=m; j++)
        //遍历dis数组,通过minn变量选择一个权值最小的边,这条边连的结点就是新标记(加入)的结点
        {
            if(!vis[j]&&dis[j]<minn)
            {
                temp=j;
                minn=dis[j];
            }
        }
        vis[temp]=1;//
        sum+=minn;//
        for(int j=1; j<=m; j++)
        //通过新加入的结点对所有dis数组进行更新
        {
            if(!vis[j]&&dis[j]>ma[temp][j])
            {
                dis[j]=ma[temp][j];
            }
        }
    }
    return sum;
}

int main()
{
    memset(vis, 0, sizeof(vis));
    memset(dis, Inf, sizeof(dis));
    scanf("%d",&m);
    for(int i=1; i<=m; i++)
        for(int j=1; j<=m; j++)
        scanf("%d",&ma[i][j]);
    int ans=Prim(1);
    printf("%d",ans);
    return 0;
}
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f
const int maxn = 110;
int a[maxn][maxn];
int dist[maxn];
int used[maxn];
int n;
int ans=0;
int num=1;

void prim()
{
    while(1)
    {
        dist[0]=0;
        int u=-1,minn=inf;
        for(int i=0; i<n; i++)
        {
            if(dist[i]<minn&&!used[i])
            {
                minn=dist[i];
                u=i;
            }
        }
        if(u==-1){
            break;
        }
        ans+=dist[u];
        used[u]=1;
        for(int v=0; v<n; v++)
        {
            if(dist[v]>a[u][v])
            {
                dist[v]=a[u][v];
            }
        }
    }

}

int main()
{
    while(scanf("%d",&n)!=EOF){
    memset(used, 0, sizeof(used));
    memset(dist, inf, sizeof(dist));
    ans=0;
    for(int i=0; i<n; i++){
        for(int j=0; j<n; j++){
            scanf("%d",&a[i][j]);
        }
    }
    prim();
    printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值