1.17 A

A - 1

Time limit 2000 ms
Memory limit 262144 kB

Problem Description

During the break the schoolchildren, boys and girls, formed a queue of n people in the canteen. Initially the children stood in the order they entered the canteen. However, after a while the boys started feeling awkward for standing in front of the girls in the queue and they started letting the girls move forward each second.

Let’s describe the process more precisely. Let’s say that the positions in the queue are sequentially numbered by integers from 1 to n, at that the person in the position number 1 is served first. Then, if at time x a boy stands on the i-th position and a girl stands on the (i + 1)-th position, then at time x + 1 the i-th position will have a girl and the (i + 1)-th position will have a boy. The time is given in seconds.

You’ve got the initial position of the children, at the initial moment of time. Determine the way the queue is going to look after t seconds.

Input

The first line contains two integers n and t (1 ≤ n, t ≤ 50), which represent the number of children in the queue and the time after which the queue will transform into the arrangement you need to find.

The next line contains string s, which represents the schoolchildren’s initial arrangement. If the i-th position in the queue contains a boy, then the i-th character of string s equals “B”, otherwise the i-th character equals “G”.

Output

Print string a, which describes the arrangement after t seconds. If the i-th position has a boy after the needed time, then the i-th character a must equal “B”, otherwise it must equal “G”.

Sample Input

5 1
BGGBG

5 2
BGGBG

4 1
GGGB

Sample Output

GBGGB

GGBGB

GGGB

问题链接:CodeForces - 266B
问题简述:

首先输入人数和秒数,再输入男女排队情况,G代表女生,B代表男生,根据相关秒数进行若干次排序

问题分析:

若B后面跟的是G则互换位置,相邻一秒只能互换一次(如一秒内BGG只能换成GBG而不能换成GGB,但BGBG换成GBGB不受影响),一秒互换一次

程序说明:

用strlen计算长度,使用冒泡排序的思想用temp充当中间物来实现互换,使用goto来解决秒数问题,如2秒则goto一次,即重复执行关键代码

AC通过的C语言程序如下:

#include <iostream>
using namespace std;

int main()
{
	int n,t;
	int num;
	int j = 1;
	char temp;
	cin >> n;
	cin >> t;
	char str1[1000];
	cin >> str1;
	num = strlen(str1);
L:;
	for (int i = 0;i < num;i++)
	{
		if (str1[i] == 'B')
		{
			if (str1[i + 1] == 'G')
			{
				temp = str1[i];
				str1[i] = str1[i + 1];
				str1[i + 1] = temp;
				i++;
			}
		}
		
	}
	for (j ;j < t;)
	{
		j++;
		goto L;
	}
	cout << str1;

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值