1.22 C

C - 3

Time limit 1000 ms
Memory limit 262144 kB

Problem Description

Mad scientist Mike entertains himself by arranging rows of dominoes. He doesn’t need dominoes, though: he uses rectangular magnets instead. Each magnet has two poles, positive (a “plus”) and negative (a “minus”). If two magnets are put together at a close distance, then the like poles will repel each other and the opposite poles will attract each other.

Mike starts by laying one magnet horizontally on the table. During each following step Mike adds one more magnet horizontally to the right end of the row. Depending on how Mike puts the magnet on the table, it is either attracted to the previous one (forming a group of multiple magnets linked together) or repelled by it (then Mike lays this magnet at some distance to the right from the previous one). We assume that a sole magnet not linked to others forms a group of its own.

在这里插入图片描述
Mike arranged multiple magnets in a row. Determine the number of groups that the magnets formed.

Input

The first line of the input contains an integer n (1 ≤ n ≤ 100000) — the number of magnets. Then n lines follow. The i-th line (1 ≤ i ≤ n) contains either characters “01”, if Mike put the i-th magnet in the “plus-minus” position, or characters “10”, if Mike put the magnet in the “minus-plus” position.

Output

On the single line of the output print the number of groups of magnets.

Sample Input

6
10
10
10
01
10
10

4
01
01
10
10

Sample Output

3

2

问题链接:C - 3
问题简述:

输入n,接下来输入n对数,每一对都由1和0组成,0代表正极,1代表负极,0和1之间会组成一块磁铁(例如01 01将会组成0101的一块磁铁),问最终构成了多少块磁铁

问题分析:

我们来看sample input
10 10 10 01 10 10
会构成101010 01 1010三块磁铁 ,容易发现组成一块的都是重复的组,即1010 或0101型的,所以找出相邻不同的每次让计数器加一即可

程序说明:

最后的for循环也应该是i<n,一开始用了i<n-1,两个for可以合并。

AC通过的C语言程序如下:
#include <iostream>
using namespace std;

int main()
{
	int a[100000];
	int n;
	cin >> n;
	int sum = 0;
	for (int i = 0;i < n;i++)
	{
		cin >> a[i];
	}
	for (int i = 0;i < n ;i++)
	{
		if (a[i] != a[i + 1])
		{
			sum++;
		}
		
	}
	cout << sum;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值