1.18 A

A - 1

Time limit 2000 ms
Memory limit 32768 kB

Problem Description

The translation from the Berland language into the Birland language is not an easy task. Those languages are very similar: a berlandish word differs from a birlandish word with the same meaning a little: it is spelled (and pronounced) reversely. For example, a Berlandish word code corresponds to a Birlandish word edoc. However, it’s easy to make a mistake during the «translation». Vasya translated word s from Berlandish into Birlandish as t. Help him: find out if he translated the word correctly.

Input

The first line contains word s, the second line contains word t. The words consist of lowercase Latin letters. The input data do not consist unnecessary spaces. The words are not empty and their lengths do not exceed 100 symbols.

Output

If the word t is a word s, written reversely, print YES, otherwise print NO.

Sample Input

code
edoc

abb
aba

code
code

Sample Output

YES

NO

NO

问题链接:A - 1
问题简述:

输入两个字符组,问是不是互相“倒相等”
如果是就“YES",不是就“NO”

问题分析:

定义数组,strlen求出长度,循环追踪就完事了

程序说明:

AC通过的C语言程序如下:
#include <iostream>
using namespace std;

int main()
{
	char a[1000];
	char b[1000];
	cin >> a;
	cin >> b;
	int a1, b1;
	a1 = strlen(a) ;
	b1 = strlen(b);
	if (a1 == b1)
	{
		for (int i = 0;i < a1;i++)
		{
			if (a[i] != b[a1 - i - 1])
			{
				cout << "NO";goto L;
			}
		}
		cout << "YES";goto L;
	}
	else { cout << "NO"; }
L:;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值