1.18 B

B - 2

Time limit 2000 ms
Memory limit 32768 kB

Problem Description

Little Petya very much likes gifts. Recently he has received a new laptop as a New Year gift from his mother. He immediately decided to give it to somebody else as what can be more pleasant than giving somebody gifts. And on this occasion he organized a New Year party at his place and invited n his friends there.

If there’s one thing Petya likes more that receiving gifts, that’s watching others giving gifts to somebody else. Thus, he safely hid the laptop until the next New Year and made up his mind to watch his friends exchanging gifts while he does not participate in the process. He numbered all his friends with integers from 1 to n. Petya remembered that a friend number i gave a gift to a friend number pi. He also remembered that each of his friends received exactly one gift.

Now Petya wants to know for each friend i the number of a friend who has given him a gift.

Input

The first line contains one integer n (1 ≤ n ≤ 100) — the quantity of friends Petya invited to the party. The second line contains n space-separated integers: the i-th number is pi — the number of a friend who gave a gift to friend number i. It is guaranteed that each friend received exactly one gift. It is possible that some friends do not share Petya’s ideas of giving gifts to somebody else. Those friends gave the gifts to themselves.

Output

Print n space-separated integers: the i-th number should equal the number of the friend who gave a gift to friend number i.

Sample Input

4
2 3 4 1

3
1 3 2

2
12

Sample Output

4 1 2 3

1 3 2

1 2

问题链接:B - 2
问题简述:

输入n,随后n个数代表有n个数据
数据代表送给那个人的序号,如2 3 4 1,代表第一个人把礼物送给了第二个人,第二个人把礼物送给了第三个人,第三个人把礼物送给了第四个人,第四个人把礼物送给了第一个人,求输出每个人送礼物的那个人的序号

问题分析:

2 3 4 1代表第一个人把礼物送给了第二个人,第二个人把礼物送给了第三个人,第三个人把礼物送给了第四个人
也就是要输出4 1 2 3

程序说明:

就这条程序all[temp] = i;

AC通过的C语言程序如下:
#include <iostream>
using namespace std;

int main()
{
	int n;
	int a, b;
	cin >> n;
	int all[200];
	int temp;
	for (int i = 1;i <= n;i++)
	{
		cin >> temp;
		all[temp] = i;
	}
	for (int i = 1;i <= n;i++)
	{
		cout << all[i] << " ";
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值