acm第二期白银训练题第一题

Y - Nearly Lucky Number

Time limit2000 msMemory limit262144 kBSourceCodeforces Beta Round #84 (Div. 2 Only)Tagsimplementation *800EditorialAnnouncement Tutorial

Problem Description

Petya loves lucky numbers. We all know that lucky numbers are the positive integers whose decimal representations contain only the lucky digits 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Unfortunately, not all numbers are lucky. Petya calls a number nearly lucky if the number of lucky digits in it is a lucky number. He wonders whether number n is a nearly lucky number.

Input
The only line contains an integer n (1 ≤ n ≤ 1018).

Please do not use the %lld specificator to read or write 64-bit numbers in С++. It is preferred to use the cin, cout streams or the %I64d specificator.

Output
Print on the single line “YES” if n is a nearly lucky number. Otherwise, print “NO” (without the quotes).

sample intput

40047

sample output

NO

sample Input

7747774

sample Output

YES

问题链接:https://vjudge.net/contest/160731#problem/Y

问题描述:输入一个整数n(1 ≤ n ≤ 10^18) 若数字n中含有4和7的总数为4或7则输出YES,否则输出NO

问题分析:对输入的数字n每一位数进行分析,计算出n中4和7的总数

程序说明:用字符数组a[19]来代替数字n的输入,分析字符数组a的每一位成员是否等于‘4’或‘7’。

c++程序如下

#include<iostream>
using namespace std;
int main()
{   char a[19];
    int k=0;
	cin>>a;
	for(int i=0;a[i]!='\0';i++)
		if(a[i]=='4'||a[i]=='7')
			k++;
	if(k==4||k==7)
		cout<<"YES"<<endl;
	else cout<<"NO"<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值