1月22号acm寒假练习第一题

Time limit1000 msMemory limit262144 kBSourceCodeforces Round #340 (Div. 2)Tagsmath *700EditorialTutorial

problem description

An elephant decided to visit his friend. It turned out that the elephant’s house is located at point 0 and his friend’s house is located at point x(x > 0) of the coordinate line. In one step the elephant can move 1, 2, 3, 4 or 5 positions forward. Determine, what is the minimum number of steps he need to make in order to get to his friend’s house.

Input
The first line of the input contains an integer x (1 ≤ x ≤ 1 000 000) — The coordinate of the friend’s house.

Output
Print the minimum number of steps that elephant needs to make to get from point 0 to point x.

Examples Input
5
Examples Output
1

Examples Input
12
Examples Output
3

问题链接:https://vjudge.net/contest/279627#problem

问题描述:输入大象要走的路程,计算大象走的最小步数。

问题分析:步数每次都走最大步数,除了走小于5就能完成以外。

程序说明:用需要走的步数除以最大步数5所得的整形数,再用要走步数对最大步数求余,若不为0,则得到的整形数+1.

#include<iostream>
using namespace std;
int main()
{   int a,b,c;
    cin>>a;
	b=a/5;
	c=a;
	if(c%5!=0)
		b++;
	cout<<b<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值