acm1月28号寒假训练第九题

Time limit2000 msMemory limit65536 kBOSLinuxSource
USACO 2007 February Silver

problem description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10

问题链接:https://vjudge.net/contest/279652#problem/I

问题描述:有N(1≤N≤1000)个农场,编号为1~N,每个农场有一头奶牛。这些奶牛将参加在#X(1≤X
≤N)号农场举行的派对。这N 个农场之间有M(1≤M≤100,000)条单向路,通过第i 条路将需要
花费Ti(1≤Ti≤100)单位时间。
每头奶牛必须走着去参加派对。派对开完以后,返回到它的农场。每头奶牛都很懒,所以总
是选择一条具有最短时间的最优路。每头奶牛的往返路线是不一样的,因为所有的路都是单向的。

问题分析:

程序分析:

c++程序如下:

#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
# define MAX 1005
# define INF 0x7FFFFFFF
using namespace std;
struct node
{
    int e;
    int value;
};
int n,m,visit[MAX];
 
void spfa(int v0,int dist[],vector<node> edge[])
{
    int i;
    queue<int> q;
    for(i=1; i<=n; i++)
        dist[i] = INF;
    dist[v0] = 0;
    q.push(v0);
    visit[v0] = 1;
    while(! q.empty())
    {
        int t = q.front();
        q.pop();
        visit[t] = 0;
        for(i=0; i<edge[t].size(); i++)
        {
            int e = edge[t][i].e;
            int value = edge[t][i].value;
            if(dist[e] > dist[t] + value)
            {
                dist[e] = dist[t] + value;
                if(visit[e] == 0)
                {
                    q.push(e);
                    visit[e] = 1;
                }
            }
        }
    }
}
 
int main()
{
    int i,x,a,b,c;
    int dist1[MAX],dist2[MAX];
    vector<node> edge1[MAX];
    vector<node> edge2[MAX];
    scanf("%d%d%d",&n,&m,&x);
    node tt;
    for(i=0; i<m; i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        tt.e = b;
        tt.value = c;
        edge1[a].push_back(tt);
        tt.e = a;
        tt. value = c;
        edge2[b].push_back(tt);
    }
    memset(visit,0,sizeof(visit));
    spfa(x,dist1,edge1);
    memset(visit,0,sizeof(visit));
    spfa(x,dist2,edge2);
    int max = -1;
    for(i=1; i<=n; i++)
    {
        if(max < dist1[i] + dist2[i] && dist1[i] != INF && dist2[i] != INF)
            max = dist1[i] + dist2[i];
    }
    printf("%d\n",max);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值