复原二叉树

题目描述

小明在做数据结构的作业,其中一题是给你一棵二叉树的前序遍历和中序遍历结果,要求你写出这棵二叉树的后序遍历结果。

输入

输入包含多组测试数据。每组输入包含两个字符串,分别表示二叉树的前序遍历和中序遍历结果。每个字符串由不重复的大写字母组成。

输出

对于每组输入,输出对应的二叉树的后续遍历结果。

样例输入

DBACEGF ABCDEFG
BCAD CBAD

样例输出

ACBFGED
CDAB

代码1

用substr()做。

#include<bits/stdc++.h>
using namespace std;
struct node
{
	char data;
	node *lchild;
	node *rchild;
};
node *creat(string a,string b)
{
	string pre1,pre2,in1,in2;
	node *root=NULL;
	if(a.size()>0)
	{
		root=new node;//申请内存 
		root->data=a[0];
		int index=b.find(a[0]);
		pre1=a.substr(1,index);
		pre2=a.substr(index+1,a.size()-1-index);
		in1=b.substr(0,index);
		in2=b.substr(index+1,b.size()-1-index);
		root->lchild=creat(pre1,in1);
		root->rchild=creat(pre2,in2);
	}
	return root;
}
void postorder(node *root)
{
	if(root==NULL)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	printf("%c",root->data);
}
int main()
{
	string a,b;
	while(cin>>a>>b)
	{
		node *t=creat(a,b);
		postorder(t);
		printf("\n"); 
	}
}

代码2

#include<bits/stdc++.h>
using namespace std;
struct node{
	char data;
	node *lchild;
	node *rchild;
};
string pre,in;
node *create(int preL,int preR,int inL,int inR){
	if(preL>preR)
		return NULL;
	node *root=new node;
	root->data=pre[preL];
	
	int k;
	for(k=inL;k<=inR;k++)
		if(in[k]==pre[preL])
			break;
	int numLeft=k-inL;
	root->lchild=create(preL+1,preL+numLeft,inL,k-1);
	root->rchild=create(preL+numLeft+1,preR,k+1,inR);
	
	return root;
}
 
void postorder(node *root){
	if(root==NULL){
		return;
	}
	postorder(root->lchild);
	postorder(root->rchild);
	printf("%c",root->data);
}
 
int main(){
	while(cin>>pre>>in){
		node *root=create(0,pre.size()-1,0,in.size()-1);
		postorder(root);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值